现在的位置: 首页 > 综合 > 正文

133 – The Dole Queue

2018年01月12日 ⁄ 综合 ⁄ 共 2066字 ⁄ 字号 评论关闭

 The Dole Queue 

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing
inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts
from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person
and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three
numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise
official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0

Sample output

tex2html_wrap_inline34 4 tex2html_wrap_inline34 8, tex2html_wrap_inline34 9 tex2html_wrap_inline34 5, tex2html_wrap_inline34 3 tex2html_wrap_inline34 1, tex2html_wrap_inline34 2 tex2html_wrap_inline34 6, tex2html_wrap_inline50 10, tex2html_wrap_inline34 7

where tex2html_wrap_inline50 represents a space.

题意:有n个人,编号为1到n,围成一个圆圈。从1开始逆时针每次数k个人,从n开始顺时针每次数m个人。数到的人出列,有可能是同一个人。出列后排队按照逆时针先,顺时针后。直到所有人都被数出来。

这道题数据不大,就直接用数组来模拟了。约瑟夫问题的延伸。如果说数据很大的话,可以用链表来做,不过这个链表还得是双向链表,也挺麻烦的。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int a[25];
int main ()
{
    int n,k,m,t,i,j,posk,posm;
    while(cin>>n>>k>>m)
    {
        if (n==0) break;
        t=0;
        memset(a,0,sizeof(a));
        posk=0;
        posm=n+1;
        while(t<n)
        {
            i=j=0;
            while(i<k)
            {
                posk++;
                if (posk>n) posk=0;
                if (!a[posk] && posk!=0) i++;
            }
            while(j<m)
            {
                posm--;
                if (posm<1) posm=n+1;
                if (!a[posm] && posm!=n+1) j++;
            }
            if (posk==posm) {
                t++;
                printf("%3d",posk);
            }
            else {
                t+=2;
                printf("%3d%3d",posk,posm);
            }
            if (t!=n) cout<<",";
            else cout<<endl;
            a[posk]=a[posm]=1;
        }

    }
}

抱歉!评论已关闭.