现在的位置: 首页 > 综合 > 正文

排序/查找 755-487-3279

2018年01月12日 ⁄ 综合 ⁄ 共 3924字 ⁄ 字号 评论关闭

  487-3279 

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of
the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza
Hut by calling their ``three tens'' number 3-10-10-10.



The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:



A, B, and C map to 2

D, E, and F map to 3

G, H, and I map to 4

J, K, and L map to 5

M, N, and O map to 6

P, R, and S map to 7

T, U, and V map to 8

W, X, and Y map to 9



There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.



Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)



Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input 

The first line of the input contains the number of datasets in the input. A blank line follows. The first line of each dataset specifies the number
of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal
digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. There's a blank line between datasets.

Output 

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard
form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.

Print a blank line between datasets.

sample input

1

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output 

310-1010 2
487-3279 4
888-4567 3


这道题之前在POJ上面做过,当时就是因为一开始把电话号码用字符串来保存,没有用数字保存,TLE了。

结果这次做,还是犯了同样的错误。。。事不过三!

这次做这个主要是想要用一下STL里面的map,熟练一下

还有就是UVa上提交不了,而且最近也上不了UVa。。不过在POJ上AC了。所以就贴一下吧

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<ctype.h>
#include<string>
#include<algorithm>
#include<map>
using namespace std;
int main ()
{
    int n,t,i,j;
    map<char, int>match;
    match.insert(pair<char,int> ('A',2)); match.insert(pair<char,int> ('B',2)); match.insert(pair<char,int> ('C',2));
    match.insert(pair<char,int> ('D',3)); match.insert(pair<char,int> ('E',3)); match.insert(pair<char,int> ('F',3));
    match.insert(pair<char,int> ('G',4)); match.insert(pair<char,int> ('H',4)); match.insert(pair<char,int> ('I',4));
    match.insert(pair<char,int> ('J',5)); match.insert(pair<char,int> ('K',5)); match.insert(pair<char,int> ('L',5));
    match.insert(pair<char,int> ('M',6)); match.insert(pair<char,int> ('N',6)); match.insert(pair<char,int> ('O',6));
    match.insert(pair<char,int> ('P',7)); match.insert(pair<char,int> ('R',7)); match.insert(pair<char,int> ('S',7));
    match.insert(pair<char,int> ('T',8)); match.insert(pair<char,int> ('U',8)); match.insert(pair<char,int> ('V',8));
    match.insert(pair<char,int> ('W',9)); match.insert(pair<char,int> ('X',9)); match.insert(pair<char,int> ('Y',9));
    cin>>n;
    for (int k=0; k<n; k++)
    {
        cin>>t;
        int num[101000]={0};
        getchar();
        char str[1000];
        for (i=0; i<t; i++)
        {
            gets(str);
            int bj=0;
            int len=strlen(str);
            for (j=0; j<len; j++)
                if (isdigit(str[j]) || isalpha(str[j]))
                {
                    if (isdigit(str[j])) num[i]=num[i]*10+(str[j]-48);
                    else num[i]=num[i]*10+match[str[j]];
                }
        }
        sort(num,num+t);
        int p=1,pp=0;
        for (i=0; i<t; i++)
        {
            if (num[i]==num[i+1]) p++;
            else if (p>1)
            {
                pp++;
                printf("%03d-%04d %d\n",num[i]/10000,num[i]%10000,p);
                p=1;
            }
        }
        if (pp==0) cout<<"No duplicates."<<endl;
        if (k<n-1) cout<<endl;
    }
    return 0;
}

抱歉!评论已关闭.