现在的位置: 首页 > 综合 > 正文

699 – The Falling Leaves

2018年01月12日 ⁄ 综合 ⁄ 共 2509字 ⁄ 字号 评论关闭

 The Falling Leaves 

Each year, fall in the North Central region is accompanied by the brilliant colors of the leaves on the trees, followed quickly by the falling leaves accumulating under the trees. If the same thing happened to binary
trees, how large would the piles of leaves become?

We assume each node in a binary tree "drops" a number of leaves equal to the integer value stored in that node. We also assume that these leaves drop vertically to the ground (thankfully, there's no wind to blow them around). Finally, we assume that the nodes
are positioned horizontally in such a manner that the left and right children of a node are exactly one unit to the left and one unit to the right, respectively, of their parent. Consider the following tree:

The nodes containing 5 and 6 have the same horizontal position (with different vertical positions, of course). The node containing 7 is one unit to the left of those containing 5 and 6, and the node containing 3
is one unit to their right. When the "leaves" drop from these nodes, three piles are created: the leftmost one contains 7 leaves (from the leftmost node), the next contains 11 (from the nodes containing 5 and 6), and the rightmost pile contains 3. (While it
is true that only leaf nodes in a tree would logically have leaves, we ignore that in this problem.)

Input 

The input contains multiple test cases, each describing a single tree. A tree is specified by giving the value in the root node, followed by the description of the left subtree, and then the description of the
right subtree. If a subtree is empty, the value 
-1 is supplied. Thus the tree shown above is specified as 5 7 -1 6 -1 -1 3 -1 -1.
Each actual tree node contains a positive, non-zero value. The last test case is followed by a single 
-1 (which would otherwise represent an empty tree).

Output 

For each test case, display the case number (they are numbered sequentially, starting with 1) on a line by itself. On the next line display the number of "leaves" in each pile, from left to right, with a single
space separating each value. This display must start in column 1, and will not exceed the width of an 80-character line. Follow the output for each case by a blank line. This format is illustrated in the examples below.

Sample Input 

5 7 -1 6 -1 -1 3 -1 -1
8 2 9 -1 -1 6 5 -1 -1 12 -1
-1 3 7 -1 -1 -1
-1

Sample Output 

Case 1:
7 11 3

Case 2:
9 7 21 15

二叉树,按照层次从上到下排列。比如根节点在(1,1)的位置,那么其左子树的根节点在(2,0),右子树的根节点在(2,2)。依次类推。最后在同一个垂直线上的叶子掉落在同一堆上,按照从左到右的顺序,依次输出这些堆的叶子数。

这同样是可以用建树来做。不过由于只是要求最后的叶子数,所以可以用递归的方式。而且输入的方式和广义表很相似。直接贴代码吧。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
int a[1000];
void go(int i, int v)
{
    a[i]+=v;
    cin>>v;
    if (v!=-1) go(i-1,v);
    cin>>v;
    if (v!=-1) go(i+1,v);
}
int main ()
{
    int n,i,t=1;
    while(cin>>n)
    {
        if (n==-1) break;
        memset(a,0,sizeof(a));
        go(1000/2,n);
        printf("Case %d:\n",t++);
        i=0;
        while(!a[i]) i++;
        cout<<a[i];
        for (i=i+1; i<1000; i++)
            if (a[i])
                cout<<" "<<a[i];
        cout<<endl<<endl;
    }
    return 0;
}

抱歉!评论已关闭.