现在的位置: 首页 > 综合 > 正文

10392 – Factoring Large Numbers

2018年01月12日 ⁄ 综合 ⁄ 共 1302字 ⁄ 字号 评论关闭

Problem F: Factoring Large Numbers

One of the central ideas behind much cryptography is that factoring large numbers is computationally intensive. In this context one might use a 100 digit number that was a product of two 50 digit
prime numbers. Even with the fastest projected computers this factorization will take hundreds of years.

You don't have those computers available, but if you are clever you can still factor fairly large numbers.

Input

The input will be a sequence of integer values, one per line, terminated by a negative number. The numbers will fit in gcc's long long int datatype. You may assume that there will be
at most one factor more than 1000000.

Output

Each positive number from the input must be factored and all factors (other than 1) printed out. The factors must be printed in ascending order with 4 leading spaces preceding a left justified number,
and followed by a single blank line.

Sample Input

90
1234567891
18991325453139
12745267386521023
-1

Sample Output

    2
    3
    3
    5

    1234567891

    3
    3
    13
    179
    271
    1381
    2423

    30971
    411522630413

把一个long long类型的大数分解质因数,保证最多只有一个大于1000000的质因数。那就直接用素数筛选法把1000000以内的素数找出来。水题

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#define maxn 1000010
using namespace std;
int a[maxn]= {0};
int main ()
{
    long long n;
    int i,j;
    for (i=2; i<1000000; i++)
        if (!a[i])
            for (j=2*i; j<1000000; j+=i)
                a[j]=1;
    while(cin>>n)
    {
        if (n<0) break;
        for (i=2; i<1000000; i++)
            if (!a[i])
            {
                while(n%i==0)
                {
                    printf("    %d\n",i);
                    n/=i;
                }
            }
        if (n>1) printf("    %lld\n",n);
        cout<<endl;
    }
    return 0;
}

抱歉!评论已关闭.