现在的位置: 首页 > 综合 > 正文

POJ 2420 A Star not a Tree?

2018年01月13日 ⁄ 综合 ⁄ 共 2510字 ⁄ 字号 评论关闭

Description

Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10base2 (coaxial) cables that allow you to connect any number of computers together in a linear arrangement. Luke is particulary proud that he solved a nasty NP-complete
problem in order to minimize the total cable length. 
Unfortunately, Luke cannot use his existing cabling. The 100mbs system uses 100baseT (twisted pair) cables. Each 100baseT cable connects only two devices: either two network cards or a network card and a hub. (A hub is an electronic device that interconnects
several cables.) Luke has a choice: He can buy 2N-2 network cards and connect his N computers together by inserting one or more cards into each computer and connecting them all together. Or he can buy N network cards and a hub and connect each of his N computers
to the hub. The first approach would require that Luke configure his operating system to forward network traffic. However, with the installation of Winux 2007.2, Luke discovered that network forwarding no longer worked. He couldn't figure out how to re-enable
forwarding, and he had never heard of Prim or Kruskal, so he settled on the second approach: N network cards and a hub. 

Luke lives in a loft and so is prepared to run the cables and place the hub anywhere. But he won't move his computers. He wants to minimize the total length of cable he must buy.

Input

The first line of input contains a positive integer N <= 100, the number of computers. N lines follow; each gives the (x,y) coordinates (in mm.) of a computer within the room. All coordinates are integers between 0 and 10,000.

题目大意

给你一个平面上的n个点,请你求出该平面上的一个任意点,使得这个点到所给n个点的距离之和最小,要求输出最小的距离和。答案四舍五入保留整数即可,

Output

Output consists of one number, the total length of the cable segments, rounded to the nearest mm.

Sample Input

4
0 0
0 10000
10000 10000
10000 0

Sample Output

28284

题解

爬山算法例题,当然也可以用模拟退火(这种做法之后补上)。

比较详尽的解释:http://hzwer.com/368.html

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<cmath>
#include<algorithm>
#define MAXN 105
#define eps 1e-8
using namespace std;
int n;
struct dian{double x,y;} d[MAXN];
double xp,yp,ans;
void init()
{
	scanf("%d",&n);
	int i;
	for(i=1;i<=n;i++)
	   {scanf("%lf%lf",&d[i].x,&d[i].y);
	    xp+=d[i].x; yp+=d[i].y;
	   }
	xp/=n; yp/=n;
}
double sqr(double x) {return x*x;}
double dis(double x,double y,dian i)
{return sqrt(sqr(x-i.x)+sqr(y-i.y));}
double calcu(double x,double y)
{
	int i;
	double sum=0;
	for(i=1;i<=n;i++) sum+=dis(x,y,d[i]);
	return sum;
}
void hill()
{
	int i;
	double k=100000,xx,yy,sum;//k是自定义的,可以看做“步幅” 
	ans=calcu(xp,yp);//自定义初始值 
	while(k>eps)
	   {xx=yy=0;
		for(i=1;i<=n;i++)
	       {xx+=(d[i].x-xp)/dis(xp,yp,d[i]);//可以看做向量,就像先找到山峰的方向 
		    yy+=(d[i].y-yp)/dis(xp,yp,d[i]);
		   }
		sum=calcu(xp+xx*k,yp+yy*k);
		if(sum<ans)
		   {ans=sum; xp+=xx*k; yp+=yy*k;}
		k=k*0.9;//越接近山顶,还要走的路越短,所以步幅要越来越小 
	   }
	printf("%.0lf\n",ans);
}
int main()
{
	init();  hill();
	return 0;
}

抱歉!评论已关闭.