现在的位置: 首页 > 综合 > 正文

BZOJ 1688: [Usaco2005 Open]Disease Manangement 疾病管理

2018年01月13日 ⁄ 综合 ⁄ 共 1555字 ⁄ 字号 评论关闭

Description

Alas! A set of D (1 <= D <= 15) diseases (numbered 1..D) is running through the farm. Farmer John would like to milk as many of his N (1 <= N <= 1,000) cows as possible.
If the milked cows carry more than K (1 <= K <= D) different diseases among them, then the milk will be too contaminated and will have to be discarded in its entirety. Please help determine the largest number of cows FJ can milk without having to discard the
milk.

Input

* Line 1: Three space-separated integers: N, D, and K * Lines 2..N+1: Line i+1 describes the diseases of cow i with a list of 1 or more space-separated integers. The first
integer, d_i, is the count of cow i's diseases; the next d_i integers enumerate the actual diseases. Of course, the list is empty if d_i is 0. 有N头牛,它们可能患有D种病,现在从这些牛中选出若干头来,但选出来的牛患病的集合中不过超过K种病.

Output

* Line 1: M, the maximum number of cows which can be milked.

Sample Input

6 3 2

0---------第一头牛患0种病

1 1------第二头牛患一种病,为第一种病.

1 2

1 3

2 2 1

2 2 1

Sample Output

5


OUTPUT DETAILS:


If FJ milks cows 1, 2, 3, 5, and 6, then the milk will have only two

diseases (#1 and #2), which is no greater than K (2).

题解

状压可过,但32767*15*1000=4亿多……我是不是时间复杂度算错了???

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cstdlib>
#include<cmath>
#include<algorithm>
using namespace std;
int n,m,k,S,ans;
int num[1002],a[1002];
void init()
{
	scanf("%d%d%d",&n,&m,&k);
	S=(1<<m)-1;
	int i,j,x;
	for(i=1;i<=n;i++)
	   {scanf("%d",&num[i]);
	    for(j=1;j<=num[i];j++)
		   {scanf("%d",&x);
			a[i]+=(1<<(x-1));
		   }
	   }
}
bool check(int x)
{
	int i,ct=0;
	for(i=0;i<m;i++)
	   {if((1<<i)&x) ct++;
	    if(ct>k) return false;
	   }
	return true;
}
void work()
{
	int i,j,ct=0;
	for(i=1;i<=S;i++)
	   {if(!check(i)) continue;
	    ct=0;
	    for(j=1;j<=n;j++)
	       {if(num[j]==0) ct++;
			else if((a[j]&i)==a[j]) ct++;
		   }
	    ans=max(ans,ct);
	   }
	printf("%d\n",ans);
}
int main()
{
	init(); work();
	return 0;
}

抱歉!评论已关闭.