现在的位置: 首页 > 综合 > 正文

bzoj1653 [Usaco2006 Feb]Backward Digit Sums

2018年01月13日 ⁄ 综合 ⁄ 共 1414字 ⁄ 字号 评论关闭

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example,
one instance of the game (when N=4) might go like this: 3 1 2 4 4 3 6 7 9 16 Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately,
the game is a bit above FJ's mental arithmetic capabilities. Write a program to help FJ play the game and keep up with the cows.

Input

* Line 1: Two space-separated integers: N and the final sum.

Output

* Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input



4 16

Sample Output



3 1 2 4


OUTPUT DETAILS:


There are other possible sequences, such as 3 2 1 4, but 3 1 2 4

is the lexicographically smallest.

看不懂题意……然后去orz了黄巨大

题意是要求一个字典序最小的全排列1到n,做n-1次操作,每次生成的新序列的第i项是原序列第i项和第i+1项的和

比如

3 1 2 4

4 3 6

7 9

16

当只有最后一项时,看一下是不是m,是就退出

看完我被惊呆了……原来algorithm头文件还有全排列这种好东西……

next_permutation自动生成当前全排列的下一项

#include<cstdio>
#include<algorithm>
using namespace std;
int n,m;
int a[20],wrk[20];
int main()
{
	scanf("%d%d",&n,&m);
	for (int i=1;i<=n;i++)a[i]=i;
	do
	{
		for (int i=1;i<=n;i++)wrk[i]=a[i];
		for (int i=1;i<n;i++)
		  for (int j=1;j<=n-i;j++)
		    wrk[j]+=wrk[j+1];
		if (wrk[1]==m)
		{
			for (int i=1;i<=n;i++)
			{
			  printf("%d",a[i]);
			  if (n-i) printf(" ");else printf("\n");
			}
			return 0;
		}
	}
	while (next_permutation(a+1,a+n+1));
	return 0;
}

抱歉!评论已关闭.