现在的位置: 首页 > 综合 > 正文

【KMP】 poj2406 Power Strings

2018年01月14日 ⁄ 综合 ⁄ 共 935字 ⁄ 字号 评论关闭
Power Strings

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the
empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

题解:kmp求循环节。
#include<cstdio>
#include<cstring>
using namespace std;
char s[1000005];
int next[1000005];
int get_next(int l)
{
    int i=0,j=-1;
    next[0]=-1;
    for(;s[i];)
        if(j==-1||s[i]==s[j])
        {
            ++i;++j;next[i]=j;
        }
        else  j=next[j];
    int x=l-next[l];
    if(l%x==0)
       return l/x;
    return 1;
}
int main()
{
    for(;scanf("%s",s);)
    {
        int len=strlen(s);
        if(s[0]=='.')  break;
        printf("%d\n",get_next(len));
    }
    return 0;
}

抱歉!评论已关闭.