现在的位置: 首页 > 综合 > 正文

【线段树】 hdu1698 Just a Hook

2018年01月14日 ⁄ 综合 ⁄ 共 2510字 ⁄ 字号 评论关闭

Just a Hook

http://acm.hdu.edu.cn/showproblem.php?pid=1698


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

 


Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents
the golden kind.
 


Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 


Sample Input
1 10 2 1 5 2 5 9 3
 


Sample Output
Case 1: The total value of the hook is 24.

//区间段内的数进行整体的更新
#include<cstdio>
#include<cstring>
using namespace std;
#define MAX 100005
int sum[MAX<<2];
void push_up(int idx)
{
    sum[idx]=(sum[idx<<1]==sum[idx<<1|1])?sum[idx<<1]:-1;
}
void build(int l,int r,int idx)//建树
{
    if(l==r)
    {
        sum[idx]=1;
        return;
    }
    int mid=(l+r)>>1;
    build(l,mid,idx<<1);
    build(mid+1,r,idx<<1|1);
    push_up(idx);
    return;
}
void updata(int l,int r,int idx,int p,int a,int b)//更新
{
    if(a<=l&&r<=b)
    {
        sum[idx]=p;
        return;
    }
    if(sum[idx]>0)
        sum[idx<<1]=sum[idx<<1|1]=sum[idx];
    int mid=(l+r)>>1;
    if(a<=mid&&sum[idx<<1]!=p) updata(l,mid,idx<<1,p,a,b);
    if(b>mid&&sum[idx<<1|1]!=p) updata(mid+1,r,idx<<1|1,p,a,b);
    push_up(idx);
}
int query(int l,int r,int idx,int a,int b)//查询
{
    if(sum[idx]>0) return sum[idx]*(r-l+1);
    int mid=(l+r)>>1;
    int res=0;
    if(a<=mid) res+=query(l,mid,idx<<1,a,b);
    if(b>mid)  res+=query(mid+1,r,idx<<1|1,a,b);
    return res;
}
int main()
{
    int cas,n,q,a,b,p;
    scanf("%d",&cas);
    for(int t=1;t<=cas;++t)
    {
        scanf("%d%d",&n,&q);
        build(1,n,1);
        for(;q--;)
        {
            scanf("%d%d%d",&a,&b,&p);
            updata(1,n,1,p,a,b);
        }
        printf("Case %d: The total value of the hook is %d.\n",t,query(1,n,1,1,n));
    }
    return 0;
}

抱歉!评论已关闭.