现在的位置: 首页 > 综合 > 正文

【BFS】Knight Moves

2018年01月14日 ⁄ 综合 ⁄ 共 2284字 ⁄ 字号 评论关闭

Knight Moves

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2898    Accepted Submission(s): 1822


Problem Description
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of
the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b. 

 


Input
The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard. 
 


Output
For each test case, print one line saying "To get from xx to yy takes n knight moves.". 
 


Sample Input
e2 e4 a1 b2 b2 c3 a1 h8 a1 h7 h8 a1 b1 c3 f6 f6
 


Sample Output
To get from e2 to e4 takes 2 knight moves. To get from a1 to b2 takes 4 knight moves. To get from b2 to c3 takes 2 knight moves. To get from a1 to h8 takes 6 knight moves. To get from a1 to h7 takes 5 knight moves. To get from h8 to a1 takes 6 knight moves. To get from b1 to c3 takes 1 knight moves. To get from f6 to f6 takes 0 knight moves.

题目是很简单的宽度优先搜索,唯一要注意的就是每次都要初始化啊。。

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
struct point
{
    int x,y;
    int moves;
};
queue<point> q;
bool map[10][10];
int dir[8][2]= {{-2,-1},{-2,1},{-1,2},{1,2},{2,1},{2,-1},{1,-2},{-1,-2}};
int sx,sy,ex,ey;
int bfs(struct point s)
{
    struct point head,temp;
    int x,y;
    map[s.x][s.y]=true;
    q.push(s);
    for(; !q.empty();)
    {
        head=q.front();
        q.pop();
        if(head.x==ex&&head.y==ey) return head.moves;
        for(int j=0; j<8; ++j)
        {
            x=head.x+dir[j][0];
            y=head.y+dir[j][1];
            if(x>0&&x<=8&&y>0&&y<=8&&map[x][y]==false)
            {
                map[x][y]=true;
                temp.x=x;
                temp.y=y;
                temp.moves=head.moves+1;
                q.push(temp);
            }
        }
    }
    return -1;
}
int main()
{
    char start[5],end[5];
    int ans,i,j;
    struct point head;
    for(; scanf("%s%s",start,end)!=EOF;)
    {
        sx=start[0]-'a'+1;
        sy=start[1]-'0';
        ex=end[0]-'a'+1;
        ey=end[1]-'0';
        head.moves=0;
        head.x=sx;
        head.y=sy;
        for(; !q.empty(); q.pop());
        memset(map,false,sizeof(map));
        printf("To get from %s to %s takes %d knight moves.\n",start,end,bfs(head));
    }
    return 0;
}

来源:http://blog.csdn.net/ACM_Ted

抱歉!评论已关闭.