现在的位置: 首页 > 综合 > 正文

【计算几何】 poj2318 TOYS

2018年01月14日 ⁄ 综合 ⁄ 共 2892字 ⁄ 字号 评论关闭
TOYS

Description

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the
toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example
toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner
and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that
the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is
random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the
rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

简单几何题目,就是找在每个区域的点数,可以通过二分查找。

#include<cstdio>
#include<cstring>
using namespace std;
#define MAX 5005
struct point
{
    long long x,y;
}a,b,toy[MAX];
int n,m;
long long up[MAX];//上端坐标
long long down[MAX];//下端坐标
long long result[MAX];//结果
long long cross(point &o,point &a,point &b)
{//返回值大于0则oa在ob的顺时针方向,返回值小于0则oa在ob的逆时针方向
    return (a.x-o.x)*(b.y-o.y)-(a.y-o.y)*(b.x-o.x);
}
int binarySearch(point k)//二分查找
{
    int st=0,en=n,mid;
    point upx,downx;
    upx.y=a.y;downx.y=b.y;
    for(;st<=en;)
    {
        mid=(st+en)/2;
        upx.x=up[mid];downx.x=down[mid];
        if(cross(downx,k,upx)<0)
           en=mid-1;
        else
           st=mid+1;
    }
    return st;
}
int main()
{
    int idx;
    for(int cas=1;scanf("%d",&n),n;++cas)
    {
        scanf("%d",&m);
        scanf("%I64d%I64d",&a.x,&a.y);
        scanf("%I64d%I64d",&b.x,&b.y);
        up[0]=down[0]=a.x;
        for(int i=1;i<=n;++i)
            scanf("%I64d%I64d",&up[i],&down[i]);
        for(int i=1;i<=m;++i)
            scanf("%I64d%I64d",&toy[i].x,&toy[i].y);
        memset(result,0,sizeof(result));
        for(int i=1;i<=m;++i)
        {
            idx=binarySearch(toy[i]);
            result[idx-1]++;
        }
        if(cas!=1)
            puts("");
        for(int i=0;i<=n;++i)
            printf("%d: %I64d\n",i,result[i]);
    }
    return 0;
}

抱歉!评论已关闭.