现在的位置: 首页 > 综合 > 正文

【二分匹配】hdu1045 Fire Net

2018年01月14日 ⁄ 综合 ⁄ 共 2947字 ⁄ 字号 评论关闭

Fire Net

http://acm.hdu.edu.cn/showproblem.php?pid=1045

Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least
one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses
in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 

 


Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The
next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 
 


Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 


Sample Input
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
 


Sample Output
5 1 5 2 4

本题可以深度优先搜索,也可以二分匹配。

把每行每列相连的空地都缩成一个点。

分别作为x部和y部,相连的条件就是有相交(即'.'的地方)。

求出最大匹配就是题目所求。

#include<cstdio>
#include<cstring>
using namespace std;
#define MAX 8
char map[MAX][MAX];
int colx[MAX][MAX],rowx[MAX][MAX];
bool path[MAX][MAX],visit[MAX];
int match[MAX];
bool SearchPath(int s,int m)
{
    for(int i=0; i<m; ++i)
    {
        if(path[s][i]&&!visit[i])
        {
            visit[i]=true;
            if(match[i]==-1||SearchPath(match[i],m))
            {
                match[i]=s;
                return true;
            }
        }
    }
    return false;
}
int main()
{
    int n,row,col;
    for(; scanf("%d",&n),n;)
    {
        getchar();
        for(int i=0; i<n; ++i)
            gets(map[i]);
        row=col=0;
        memset(colx,-1,sizeof(colx));
        memset(rowx,-1,sizeof(rowx));
        for(int i=0; i<n; ++i)
        {
            for(int j=0; j<n; ++j)
            {
                if(map[i][j]=='.'&&rowx[i][j]==-1)
                {
                    for(int k=j; map[i][k]=='.'&&k<n; ++k)
                        rowx[i][k]=row;
                    ++row;
                }
                if(map[j][i]=='.'&&colx[j][i]==-1)
                {
                    for(int k=j; map[k][i]=='.'&&k<n; ++k)
                        colx[k][i]=col;
                    col++;
                }
            }
        }
            memset(path,false,sizeof(path));
            for(int i=0;i<n;++i)
                for(int j=0;j<n;++j)
                    if(map[i][j]=='.')
                        path[rowx[i][j]][colx[i][j]]=true;
            int summ=0;
            memset(match,-1,sizeof(match));
            for(int i=0; i<row; ++i)
            {
                memset(visit,false,sizeof(visit));
                if(SearchPath(i,col))
                    summ++;
            }
            printf("%d\n",summ);
    }
    return 0;
}

抱歉!评论已关闭.