现在的位置: 首页 > 综合 > 正文

【二分匹配】 hdu1083 Courses

2018年01月14日 ⁄ 综合 ⁄ 共 2334字 ⁄ 字号 评论关闭

Courses

http://acm.hdu.edu.cn/showproblem.php?pid=1083

Problem Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
...... 
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P,
each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course,
each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:

 


Sample Input
2 3 3 3 1 2 3 2 1 2 1 1 3 3 2 1 3 2 1 3 1 1
 


Sample Output
YES NO

题意:要从每个选了本课程的学生中挑选一个当代表,要求每个课程都要选出一个人,而且每个人只能当选一个课程的代表,问能否达成上述要求。

解法:很吃果果的二分匹配,求出最大匹配数是否等于课程数,是则可以完成。

//匈牙利算法
#include<cstdio>
#include<cstring>
using namespace std;
#define MAX 305
bool path[MAX][MAX],visit[MAX];
int match[MAX];
bool SearchPath(int s,int m)
{
    for(int i=1; i<=m; ++i)
    {
        if(path[s][i]&&!visit[i])
        {
            visit[i]=true;
            if(match[i]==-1||SearchPath(match[i],m))
            {
                match[i]=s;
                return true;
            }
        }
    }
    return false;
}
int main()
{
    int T,n,m,t,b;
    scanf("%d",&T);
    for(;T--;)
    {
        memset(path,false,sizeof(path));
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;++i)
        {
            scanf("%d",&t);
            for(;t--;)
            {
                scanf("%d",&b);
                path[i][b]=true;
            }
        }
        int summ=0;
        memset(match,-1,sizeof(match));
        for(int i=1; i<=n; ++i)
        {
            memset(visit,false,sizeof(visit));
            if(SearchPath(i,m))
                summ++;
        }
        if(summ==n)
            puts("YES");
        else
            puts("NO");
    }
    return 0;
}

来源:http://blog.csdn.net/acm_ted/article/details/7779464

抱歉!评论已关闭.