现在的位置: 首页 > 综合 > 正文

POJ 3254 Corn Fields

2018年01月14日 ⁄ 综合 ⁄ 共 1869字 ⁄ 字号 评论关闭
Corn Fields
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 5764   Accepted: 3053

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares
are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice
as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways
he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

dp[cur][i]表示状态为i时的方案数
#include<cstdio>
#include<cstring>

#define maxn 1<<12
#define mod 100000000

int dp[2][maxn];

int main()
{
	int M,N;
	int i,j,k,cur,pre,tmp,num;
//	freopen("e:\\in.txt","r",stdin);

	while(scanf("%d%d",&N,&M)==2)
	{
		cur=1;	memset(dp[cur],0,sizeof(dp[cur]));
		dp[cur][0]=1;
		for(i=1;i<=N;i++)
		{
			pre=cur;	cur=(pre+1)%2;
			memset(dp[cur],0,sizeof(dp[cur]));
			num=0;
			for(j=0;j<M;j++)
			{
				scanf("%d",&tmp);
				if(tmp)
					num+=(1<<j);
			}

			for(j=0;j<(1<<M);j++)
			{
				if((j&num)<j)
					continue;
				if(j&(j<<1))
					continue;
				for(k=0;k<(1<<M);k++)
				{
					if(j&k)
						continue;
					dp[cur][j]=(dp[cur][j]+dp[pre][k])%mod;
				}
			}
		}
		int S=0;
		for(i=0;i<(1<<M);i++)
			S=(S+dp[cur][i])%mod;
		printf("%d\n",S);
	}
	return 0;
}

抱歉!评论已关闭.