现在的位置: 首页 > 综合 > 正文

Hdu 1520 Anniversary party

2018年01月15日 ⁄ 综合 ⁄ 共 1762字 ⁄ 字号 评论关闭

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E.
Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached
to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
 

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number
in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:

L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line

0 0
 

Output
Output should contain the maximal sum of guests' ratings.
 

Sample Input
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

Sample Output
5
 

一道很简单和常规的树形DP题

d[i][0]表示以结点i为根的子树不选i结点的最大值
d[i][1]表示以结点i为根的子树选i结点的最大值

#include<cstdio>
#include<cstring>
#include<vector>

using namespace std;

#define Max(a,b) (a>b?a:b)

int Val[6100];
bool vis[6100];
vector<int> son[6100];
int d[6100][2];

void DFS(int x)
{
	int v;
	d[x][0]=0;
	d[x][1]=Val[x];
	for(int i=0;i<son[x].size();i++)
	{
		v=son[x][i];
		DFS(v);
		d[x][0]+=Max(d[v][0],d[v][1]);
		d[x][1]+=d[v][0];
	}
}

int main()
{
	int N;
	int i,u,v;

	while(scanf("%d",&N)==1)
	{
		for(i=1;i<=N;i++)
		{
			scanf("%d",&Val[i]);
			son[i].clear();
		}
		memset(vis,0,sizeof(vis));
		while(scanf("%d%d",&v,&u),v||u)
		{
			vis[v]=1;
			son[u].push_back(v);
		}
		for(i=1;i<=N;i++)
		{
			if(!vis[i])
			{
				DFS(i);
				break;
			}
		}
		printf("%d\n",Max(d[i][0],d[i][1]));

	}
}

抱歉!评论已关闭.