现在的位置: 首页 > 综合 > 正文

Poj 2184 Cow Exhibition

2018年01月15日 ⁄ 综合 ⁄ 共 2393字 ⁄ 字号 评论关闭

                                                                              Cow Exhibition 

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6972   Accepted: 2468

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much
fun..."
- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for
each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS
and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input

* Line 1: A single integer N, the number of cows

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.

Source

这个题不错。

纠结了很久,想不到这样的01背包变形,程序调试的时候也很纠结!!!!

零点的代码里,当重量是正数与负数时分开处理,处理时价值的方向不同,这点需要学习与注意


#include<stdio.h>

#define MAXN 101

int w[MAXN],v[MAXN];
int f[200001];

int main(void)
{
	int N,max,min;
//	freopen("d:\\in.txt","r",stdin);
//	freopen("d:\\out.txt","w",stdout);
	while(scanf("%d",&N)==1)
	{
		int i,j;
		max=0,min=0;
		for(i=1;i<=N;i++)
		{
			scanf("%d%d",&w[i],&v[i]);
			max=w[i]>0?max+w[i]:max;
			min=w[i]<0?min+w[i]:min;
		}
		min+=100000;
		max+=100000;
//		printf("min=%d  max=%d\n",min,max);
		for(i=min;i<=max;i++)
		{
			f[i]=-100000000;
		}
		f[100000]=0;
//		f[min]=0;
		for(i=1;i<=N;i++)
		{
			if(w[i]>=0)
				for(j=max;j>=min+w[i];j--)
				{
						if(f[j]-w[i]!=-100000000)
						f[j]=f[j]>f[j-w[i]]+v[i]?f[j]:f[j-w[i]]+v[i];
				}
			else
				for(j=min;j<=max+w[i];j++)
				{
					if(f[j-w[i]]!=-100000000)
						f[j]=f[j]>f[j-w[i]]+v[i]?f[j]:f[j-w[i]]+v[i];
				}
		}
		int tmp=-100000000;
		for(i=100000;i<=max;i++)
		{
//			printf("%d\n",f[i]);
			if(f[i]>=0)
				tmp=tmp>i-100000+f[i]?tmp:i-100000+f[i];
		}
		tmp=tmp>0?tmp:0;
		printf("%d\n",tmp);
	}
	return 0;
}

抱歉!评论已关闭.