现在的位置: 首页 > 综合 > 正文

Hdu 1016 Prime Ring Problem

2018年01月15日 ⁄ 综合 ⁄ 共 1398字 ⁄ 字号 评论关闭

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14686    Accepted Submission(s): 6709

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in
lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

 

Sample Input
6 8
 

Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
 

Recommend
JGShining

#include<stdio.h>

int n;
int num[41]={0,0,1,1,0,1,0,1,0,0,0,
               1,0,1,0,0,0,1,0,1,0,
               0,0,1,0,0,0,0,0,1,0,
               1,0,0,0,0,0,1,0,0,0
};
int flag[41];
int nn[21];

void dfs(int x,int t)
{
    int i;
    if(t==n)
    {
        if(num[x+1])
        {
            int i;
            printf("1");
            for(i=2;i<=n;i++)
                printf(" %d",nn[i]);
            printf("\n");
        }
        return ;
    }
    for(i=2;i<=n;i++)
    {
        if(!flag[i] && num[i+x])
        {
            flag[i]=1;
            nn[t+1]=i;
            dfs(i,t+1);
            flag[i]=0;
        }
    }

}

int main(void)
{
    int m=1;
    while(scanf("%d",&n)==1)
    {
        int i;
        printf("Case %d:\n",m++);
        if(n==1)
            printf("1\n");
        if(n%2 && n!=1)
            printf("\n");
        else
        {
            for(i=1;i<=n;i++)
                flag[i]=0;
            for(i=2;i<=n;i++)
            {
                if(num[i+1])
                {
                    flag[i]=1;
                    nn[2]=i;
                    dfs(i,2);
                    flag[i]=0;
                }
            }
        }
        printf("\n");
    }
    return 0;
}

【上篇】
【下篇】

抱歉!评论已关闭.