现在的位置: 首页 > 综合 > 正文

hd 1102 Constructing Roads

2018年01月15日 ⁄ 综合 ⁄ 共 1786字 ⁄ 字号 评论关闭

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8280    Accepted Submission(s): 3107

Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B,
or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within
[1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 

Sample Input
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
179
 

Source
 

Recommend
Eddy

对于已经连接的道路,直接假设他们的距离为0,然后用prim算法求最小生成树

-1代表改结点已用

#include<stdio.h>

int N;

int num[101][101];
int closedge[101];

int min()
{
	int i,j,tmp=1000000000;
	for(i=2;i<=N;i++)
	{
		if(closedge[i]!=-1&&closedge[i]<tmp)
		{
			j=i;
			tmp=closedge[i];
		}
	}
	return j;
}

int main()
{
	while(scanf("%d",&N)==1)
	{
		int i,Q,j,k,s=0;
		for(i=1;i<=N;i++)
			for(j=1;j<=N;j++)
			{
				scanf("%d",&num[i][j]);
			}
		scanf("%d",&Q);
		for(i=1;i<=Q;i++)
		{
			scanf("%d%d",&j,&k);
			num[j][k]=num[k][j]=0;
		}
		for(i=2;i<=N;i++)
		{
			closedge[i]=num[1][i];
		}
		closedge[1]=-1;
		for(i=1;i<N;i++)
		{
			k=min();
			s+=closedge[k];
			closedge[k]=-1;
			for(j=2;j<=N;j++)
			{
				if(num[k][j]<closedge[j])
				{
					closedge[j]=num[k][j];
				}
			}
		}
		printf("%d\n",s);


	}
	return 0;
}

抱歉!评论已关闭.