现在的位置: 首页 > 综合 > 正文

Hdu 1729 Stone Game

2018年01月15日 ⁄ 综合 ⁄ 共 1960字 ⁄ 字号 评论关闭

Stone Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)

Problem Description
This game is a two-player game and is played as follows:

1. There are n boxes; each box has its size. The box can hold up to s stones if the size is s.
2. At the beginning of the game, there are some stones in these boxes.
3. The players take turns choosing a box and put a number of stones into the box. The number mustn’t be great than the square of the number of stones before the player adds the stones. For example, the player can add 1 to 9 stones if there are 3 stones in the
box. Of course, the total number of stones mustn’t be great than the size of the box.
4.Who can’t add stones any more will loss the game.

Give an Initial state of the game. You are supposed to find whether the first player will win the game if both of the players make the best strategy.

 

Input
The input file contains several test cases.
Each test case begins with an integer N, 0 < N ≤ 50, the number of the boxes.
In the next N line there are two integer si, ci (0 ≤ ci ≤ si ≤ 1,000,000) on each line, as the size of the box is si and there are ci stones in the box.
N = 0 indicates the end of input and should not be processed.
 

Output
For each test case, output the number of the case on the first line, then output “Yes” (without quotes) on the next line if the first player can win the game, otherwise output “No”.
 

Sample Input
3 2 0 3 3 6 2 2 6 3 6 3 0
 

Sample Output
Case 1: Yes Case 2: No
 

Source
“网新恩普杯”杭州电子科技大学程序设计邀请赛

(S,S)这个局面是必败局面。

对于每一堆能加的数量有限,而当c的值(大于或者等于)D=sqrt(s) 或者 D=sqri(s)+1的时候就可以一次完成,从当前局面可以到达(S,S)的局面,所以当前局面是必胜局面。

而这种情况下,你能造成的局面有集合A={0,1,2,...,s-c-1};因为你可以去s-c,s-c-1,s-c-2,.....,1;那么对应mex(x)函数(即A中未出现的最小的一个数字),那么自然该局面的SG值就是s-c了;

假如(s,d)是一个奇异局势,那么达到(s,d)这个点后,我们所能放下的石子数为 d+1 ~ d+d*d,

所以 d+d*d<s

如果再假设当前走到了(d+1)点,那么一定满足 (d+1)+(d+1)*(d+1)>=s

由 S 我们就可以求出他的必败点 d (也就是(s,d)为奇异局势)

如果 d > c 那么只需要继续找下去 ,把 d 当成 s 就ok了。直到找到大于c的最小必败点 。

#include<cstdio>
#include<cmath>

int fun(int s,int c)
{
	int tmp=int(sqrt(double(s)))+1;
	while(tmp*tmp+tmp>=s)
		tmp--;
	if(c==tmp)
		return 0;
	if(c>tmp)
		return s-c;
	return fun(tmp,c);
}

int main()
{
	int N,flag;
	int c,s,t=1;

	while(scanf("%d",&N),N)
	{
		flag=0;
		while(N--)
		{
			scanf("%d%d",&s,&c);
			flag^=fun(s,c);
		}
		printf("Case %d:\n",t++);
		if(flag)
			printf("Yes\n");
		else
			printf("No\n");
	}

	return 0;
}

抱歉!评论已关闭.