现在的位置: 首页 > 综合 > 正文

Hdu 1517 A Multiplication Game

2018年01月15日 ⁄ 综合 ⁄ 共 845字 ⁄ 字号 评论关闭

A Multiplication Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2717    Accepted Submission(s): 1553

Problem Description
Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game
starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.
 

Input
Each line of input contains one integer number n.
 

Output
For each line of input output one line either

Stan wins.

or

Ollie wins.

assuming that both of them play perfectly.

 

Sample Input
162 17 34012226
 

Sample Output
Stan wins. Ollie wins. Stan wins.
 
#include<cstdio>

int main()
{
    __int64 n;
    __int64 x,flag;
    while(scanf("%I64d",&n)==1)
    {
        x=1;
        flag=0;
        while(x<n)
        {
            x*=9;
            flag++;
            if(x>=n)
                break;
            x*=2;
            flag++;
        }
        if(flag%2)
            printf("Stan wins.\n");
        else
            printf("Ollie wins.\n");
    }
    return 0;
}

抱歉!评论已关闭.