现在的位置: 首页 > 综合 > 正文

POJ 3094 Quicksum

2018年01月17日 ⁄ 综合 ⁄ 共 1801字 ⁄ 字号 评论关闭
Quicksum
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14417   Accepted: 10050

Description

A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and
in many other situations where it is necessary to detect undesirable changes in data.

For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including
consecutive spaces.

A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example
Quicksum calculations for the packets "ACM" and "MID CENTRAL":

        ACM: 1*1  + 2*3 + 3*13 = 46

MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650

Input

The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.

Output

For each packet, output its Quicksum on a separate line in the output.

Sample Input

ACM
MID CENTRAL
REGIONAL PROGRAMMING CONTEST
ACN
A C M
ABC
BBC
#

Sample Output

46
650
4690
49
75
14
15

Source

解题思路:
这道题很水,注意输入的时候用到gets()就好了,因为如果用cin或者scanf输入的话,会产生一个很SB的问题,就是在处理" "的时候,会被当做是第二次输入,但用gets()就能好的避免这个问题,避免这个问题后,就是对于sum的维护了,不说了很水,把字母转化成数字的时候记住A的ASCII为65就好了...
代码:
# include<cstdio>
# include<iostream>
# include<cstring>

using namespace std;

# define MAX 256

char s[MAX];

char s1[123];
int main(void)
{
    char ch;
    int len;
    while( gets(s) )
    {
        int sum = 0;
        if ( s[0] == '#' )
            break;

        int len = strlen(s);

        for ( int i = 0;i < len;i++ )
        {
            if ( s[i] == ' ' )
                    continue;
                else
                    {
                    sum += (i+1)*( s[i] - 65 + 1 );
                    //cout<<sum<<endl;
                    }
        }
        cout<<sum<<endl;


    }




    return 0;
}

抱歉!评论已关闭.