现在的位置: 首页 > 综合 > 正文

POJ 2262 Goldbach’s Conjecture

2018年01月17日 ⁄ 综合 ⁄ 共 1735字 ⁄ 字号 评论关闭
Goldbach's Conjecture
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 38917   Accepted: 14906

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 
Every even number greater than 4 can be 
written as the sum of two odd prime numbers.

For example: 

8 = 3 + 5. Both 3 and 5 are odd prime numbers. 
20 = 3 + 17 = 7 + 13. 
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 
Each test case consists of one even integer n with 6 <= n < 1000000. 
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair
where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

Source

解题思路:

和刚才上面有一道题很像,但是这道题的数据变大了 1000000,第一次用了O(n^2) 果断TLE了,其实不用这么SB的算法,只要在这个筛选出来的素数表中把

n-i和i的项找出来,分别判断两者是否同时为1就可以了,如果两者同时为1,那么,就可以认为找到了,这组我们需要的解,如果两者不同时为1,那么就continue.如果i的变化范围超过了n/2都没有找到合适的解,那么就可以认为无解了.

代码:

# include<cstdio>
# include<iostream>

using namespace std;

# define MAX 1000000

int a[MAX];
int b[MAX];

void dabiao()
    {
        for ( int i = 2;i <= MAX;i++ )
                a[i] = 1;
            for ( int i = 2;i <= MAX;i++ )
                {
                    if ( a[i] == 1  )
                        {
                            for ( int j = 2*i;j <= MAX;j+=i )
                                {
                                    if ( j%i == 0 )
                                        a[j] = 0;
                                }
                        }

                }
    }

int main(void)
{
    dabiao();
    int n;

    while ( cin>>n )
        {
             int x = 0;
             int y = 0;

            if ( n == 0 )
                break;

            int i;
            for ( i = 3;i <= n/2;i++ )
                {
                    if ( a[i] == 1 && a[n-i] == 1 )
                        {
                            printf("%d = %d + %d\n", n, i, n-i);
                            break;
                        }

                }
                if ( i > n/2 )
                   {
                         printf("Goldbach's conjecture is wrong.\n");
                    }






        }



      //  }




    return 0;
}

【上篇】
【下篇】

抱歉!评论已关闭.