现在的位置: 首页 > 综合 > 正文

HDU 1387 Team Queue 队列的模拟

2018年01月19日 ⁄ 综合 ⁄ 共 2859字 ⁄ 字号 评论关闭

Team Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1256    Accepted Submission(s): 430

Problem Description
Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a
team queue, for example.
In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them.
If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.

Your task is to write a program that simulates such a team queue.

Input
The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves.
Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

ENQUEUE x - enter element x into the team queue
DEQUEUE - process the first element and remove it from the queue
STOP - end of test case
The input will be terminated by a value of 0 for t.

 
Output
For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even
after the last one.
 
Sample Input
2 3 101 102 103 3 201 202 203 ENQUEUE 101 ENQUEUE 201 ENQUEUE 102 ENQUEUE 202 ENQUEUE 103 ENQUEUE 203 DEQUEUE DEQUEUE DEQUEUE DEQUEUE DEQUEUE DEQUEUE STOP 2 5 259001 259002 259003 259004 259005 6 260001 260002 260003 260004 260005 260006 ENQUEUE 259001 ENQUEUE 260001 ENQUEUE 259002 ENQUEUE 259003 ENQUEUE 259004 ENQUEUE 259005 DEQUEUE DEQUEUE ENQUEUE 260002 ENQUEUE 260003 DEQUEUE DEQUEUE DEQUEUE DEQUEUE STOP 0

Sample Output
Scenario #1 101 102 103 201 202 203 Scenario #2 259001 259002 259003 259004 259005 260001
/*
HDU 1387 队列的模拟 

每个团体对应一个标号,用该标号对应队列数组。
元素入队时先入队列数组,如果该队列没在总的队列中,就把该队列的标号压入总队列,对队列的标号进行标记。
出队是出的是总队列队首标号指向的队列数组中的队列的队首元素,如果出队后该队列为空,总队列队首出队,该队列的标号恢复为未标记。
*/

#include<iostream>
#include<stdio.h>
#include<queue>
#include<map>
#include<cstring>
using namespace std;
int main()
{
	int n,m,i,t,cas=1;
	int vis[1002];
	char str[10];
	
	//freopen("test.txt","r",stdin);
	while(scanf("%d",&n),n)
	{
		queue<int> q[1002],que;//que存储总的队列 q是每个小的队列 
		map<int,int> team;//每个元素所对应的组 
		
		for(i=0;i<n;i++)
		{
			scanf("%d",&m);
			while(m--)	
			{
				scanf("%d",&t);
				team[t]=i;//当前这个元素 是第i组 
			}
		}
		memset(vis,0,sizeof(vis));
        printf("Scenario #%d\n",cas++);
        
		while(scanf("%s",str))
		{
			if(strcmp(str,"STOP")==0)
			{
				printf("\n");
				break;
			}
			else if(strcmp(str,"ENQUEUE")==0)
			{
				scanf("%d",&t);
				q[team[t]].push(t);//team[t]都存在 
				if(vis[team[t]]==0)//这个组不存在 
				{
					que.push(team[t]);
					vis[team[t]]=1;
				}
			}
			else
			{
				printf("%d\n",q[que.front()].front());
				q[que.front()].pop();
				if(q[que.front()].empty())//空 
				{
					vis[que.front()]=0;
					que.pop();
				}
			}
		}
	}
	return 0; 
} 

抱歉!评论已关闭.