现在的位置: 首页 > 综合 > 正文

HDU 1398 Square Coins 母函数

2018年01月19日 ⁄ 综合 ⁄ 共 1692字 ⁄ 字号 评论关闭

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8404    Accepted Submission(s): 5721

Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ...,
and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

 

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.
 

Sample Input
2 10 30 0
 

Sample Output
1 4 27
/*
HDOJ 1398 母函数 
1,4,9,16...289 

砝码:(1+x)(1+x^2)(1+x^3)(1+x^4)=1+x+x^2+2x^3+2x^4+2x^5+2x^6+2x^7+x^8+x^9+x^10 ,系数即为方案数。
x表示砝码,x的指数表示重量
都是一个的情况,例称出重量为6的物品:①、1,2,3;②、2,4两种方案。

所以这里:
G(x)=(1+x+x^2+…)(1+x^4+x^8+…)…(1+x^289+x^578+…),然后每次查询相当于查询x^n的系数是多少。
*/ 

#include<iostream>
#include<stdio.h>
using namespace std;
// c1是保存各项质量砝码可以组合的数目
// c2是中间量,保存没一次的情况

int c1[10002],c2[10002];
int main()
{
	int i,j,k,sum;
	while(scanf("%d",&sum),sum)
	{
		for(i=0;i<=sum;i++)// 首先对c1初始化,由第一个表达式(1+x+x2+..xn)初始化
		{
			c1[i]=1;
			c2[i]=0;
		}
		
		for(i=2;i*i<=sum;i++)//钱的种类数目 最大就是sum/(i*i) 
		{
			for(j=0;j<=sum;j++)//第j个变量 
			{
					//k表示的是第j个指数,所以k每次增i(因为第i个表达式的增量是i)
					for(k=0;k+j<=sum;k+=i*i)
						c2[k+j]+=c1[j];
				
			}
			for(j=0;j<=sum;j++)  
            {  
                c1[j]=c2[j];  
                c2[j]=0;  
            }
		}
		printf("%d\n",c1[sum]);	
	}
	return 0;
} 

抱歉!评论已关闭.