现在的位置: 首页 > 综合 > 正文

HDU shǎ崽 OrOrOrOrz Time 2673 排序输出

2018年01月19日 ⁄ 综合 ⁄ 共 1163字 ⁄ 字号 评论关闭

shǎ崽 OrOrOrOrz

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7040    Accepted Submission(s): 3357

Problem Description
Acmer in HDU-ACM team are ambitious, especially shǎ崽, he can spend time in Internet bar doing problems overnight. So many girls want to meet and Orz him. But Orz him is not that easy.You must solve this problem first.
The problem is :
Give you a sequence of distinct integers, choose numbers as following : first choose the biggest, then smallest, then second biggest, second smallest etc. Until all the numbers was chosen .

For example, give you 1 2 3 4 5, you should output 5 1 4 2 3
 
Input
There are multiple test cases, each case begins with one integer N(1 <= N <= 10000), following N distinct integers.
 
Output
Output a sequence of distinct integers described above.
 
Sample Input
5 1 2 3 4 5
 
Sample Output
5 1 4 2 3

/*
2673 shǎ崽 OrOrOrOrz
给定一个序列 先最大 最小 再继续下去。。 
5
1 2 3 4 5
*/

#include<iostream>
#include<algorithm>
using namespace std;

bool cmp(int a,int b)
{
    return a>b;
}

int main(){
    int n,i,k1,k2,t[10001];
    
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<n;i++)
            scanf("%d",&t[i]);
        sort(t,t+n,cmp);
        k1=1;k2=n-1;
        printf("%d",t[0]);
        for(i=1;i<n;i++)
            if(i%2==1)    printf(" %d",t[k2--]);
                else printf(" %d",t[k1++]);
        printf("\n");
    } 
    return 0;
}

抱歉!评论已关闭.