现在的位置: 首页 > 综合 > 正文

HDU 1718 Rank 排序查找,成绩排名

2018年01月19日 ⁄ 综合 ⁄ 共 1375字 ⁄ 字号 评论关闭

Rank

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3885    Accepted Submission(s): 1510

Problem Description
Jackson wants to know his rank in the class. The professor has posted a list of student numbers and marks. Compute Jackson’s rank in class; that is, if he has the top mark(or is tied for the top mark) his rank is 1; if he has the
second best mark(or is tied) his rank is 2, and so on.
Input
The input consist of several test cases. Each case begins with the student number of Jackson, an integer between 10000000 and 99999999. Following the student number are several lines, each containing a student number between 10000000
and 99999999 and a mark between 0 and 100. A line with a student number and mark of 0 terminates each test case. There are no more than 1000 students in the class, and each has a unique student number.
Output
For each test case, output a line giving Jackson’s rank in the class.
Sample Input
20070101 20070102 100 20070101 33 20070103 22 20070106 33 0 0
Sample Output
/*
Rank 排序查找 名次 
*/

#include<iostream>
#include<algorithm>
using namespace std;

struct student{
    int id;
    int score;
};

bool cmp(student a,student b)
{
    return a.score>b.score;
}
int main(){
    student stu[1001];
    int m,n,k,i;
    while(scanf("%d",&n)!=EOF)
    {
        k=1;
        while(scanf("%d%d",&stu[k].id,&stu[k].score))
        {
            k++;
            if (stu[k-1].id==0&&stu[k-1].score==0) break;
        }
        sort(stu+1,stu+k,cmp);

        for(i=1;i<k;i++)
            if(stu[i].id==n) break;
        m=i;
        i=1;
        while(stu[i].score!=stu[m].score) i++;
        printf("%d\n",i);    
    }
    return 0;
}

抱歉!评论已关闭.