现在的位置: 首页 > 综合 > 正文

HDU 1787 GCD Again 欧拉函数

2018年01月19日 ⁄ 综合 ⁄ 共 1440字 ⁄ 字号 评论关闭

GCD Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2452    Accepted Submission(s): 1007

Problem Description
Do you have spent some time to think and try to solve those unsolved problem after one ACM contest?
No? Oh, you must do this when you want to become a "Big Cattle".
Now you will find that this problem is so familiar:
The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little
more difficult problem:
Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1.
This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study.
Good Luck!
 

Input
Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed.
 

Output
For each integers N you should output the number of integers M in one line, and with one line of output for each line in input.
 

Sample Input
2 4 0
 

Sample Output
0 1
/*
HDOJ 1787 欧拉函数 
这里用的是单独求欧拉函数的模版 
*/

#include<iostream>
#include<stdio.h>
using namespace std;
#define N 100000000

int phi(int x)
{
	int i,ans=x;

	for(i=2;i*i<=x;i++)
	{
		if(x%i==0)
		{
			ans-=ans/i;
			//ans=ans/i*(i-1); 两个公式一样的效果 
			while(x%i==0)//i肯定是素数 
				x/=i;
		}
	}
	if(x>1)
		ans=ans/x*(x-1);
	return ans;
}

int main()
{
	int n;
	while(scanf("%d",&n),n)
	{
		printf("%d\n",n-phi(n)-1);
	}
	return 0;
}

抱歉!评论已关闭.