现在的位置: 首页 > 综合 > 正文

HDU 5146 Sequence 判断序列不是回文 且奇数与偶数位的和不同

2018年01月19日 ⁄ 综合 ⁄ 共 1310字 ⁄ 字号 评论关闭

Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 173    Accepted Submission(s): 126

Problem Description
Today we have a number sequence A includes n elements.
Nero thinks a number sequence A is good only if the sum of its elements with odd index equals to the sum of its elements with even index and this sequence is not a palindrome.
Palindrome means no matter we read the sequence from head to tail or from tail to head,we get the same sequence.
Two sequence A and B are consider different if the length of A is different from the length of B or there exists an index i that
AiBi.
Now,give you the sequence A,check out it’s good or not.
Input
The first line contains a single integer T,indicating the number of test cases.
Each test case begins with a line contains an integer n,the length of sequence A.
The next line follows n integers A1,A2,,An.
[Technical Specification]
1 <= T <= 100
1 <= n <= 1000
0 <= Ai
<= 1000000
Output
For each case output one line,if the sequence is good ,output "Yes",otherwise output "No".
Sample Input
3 7 1 2 3 4 5 6 7 7 1 2 3 5 4 7 6 6 1 2 3 3 2 1
Sample Output
No Yes No

/*
5146 
判断序列不是回文 且奇数与偶数位的和不同 
*/
#include<iostream>
#include<stdio.h>
using namespace std;
int a[1001];
int main()
{
	int t,n,sum,i,j,f;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		sum=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			if(i&1==1)
				sum+=a[i];
			else
				sum-=a[i];
		}	
		f=0;
		for(i=0,j=n-1;i<=j;i++,j--)
		{
			if(a[i]!=a[j])
			{
				f=1;
				break;			
			}		
		}
		if(sum==0&&f==1)
			printf("Yes\n");
		else
			printf("No\n");	
	}
	return 0;
}

抱歉!评论已关闭.