现在的位置: 首页 > 综合 > 正文

HDU 1102 Constructing Roads 最小生成树

2018年01月20日 ⁄ 综合 ⁄ 共 2044字 ⁄ 字号 评论关闭

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14327    Accepted Submission(s): 5454

Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B,
or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within
[1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 

Sample Input
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
179
/*
HDOJ 1102 
最小生成树 Prime算法 
首先有两个集合V{},边的集合E{}。 
先选择一个点,加入到V集合中, 
然后已经在这个V集合中的点 相连的边中最小的, 
将边的另一头的点加入到V集合中,该边加入到E集合中, 
每次找和这个连通图相连的最短边,来更新。

输出最小的值 
*/
#include<iostream>
#include<stdio.h>
using namespace std;

const int N=105;
#define INF 100000000
const int MAX=N*(N-1)/2;

int n,m;
int map[N][N];
int dis[MAX],vis[MAX];
//dis[] 表示的是第一个节点到每个节点的距离 vis[]是否访问 

void Prime()
{
    int i,j,sum,min,loc;
    
    memset(vis,0,sizeof(vis));
    for(i=1;i<=n;i++)
    {
        if(i==1) dis[i]=0;
            else dis[i]=map[1][i];
    }
    sum=0;
    for(i=1;i<=n;i++)
    {
        min=INF;
        for(j=1;j<=n;j++)
        {
            if(!vis[j]&&dis[j]<min)
            {
                min=dis[j];
                loc=j;
            }
        }
        
        vis[loc]=1;
        sum+=min;
        for(j=1;j<=n;j++)
        {
            if(!vis[j]&&map[loc][j]<dis[j])//loc到j的值 小于dis[j]
                dis[j]=map[loc][j]; 
        }    
    }
    printf("%d\n",sum);
}

int main()
{
    int i,j,a,b;
    
    //freopen("test.txt","r",stdin);
    while(scanf("%d",&n)!=EOF)
    {
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
                scanf("%d",&map[i][j]);
        scanf("%d",&m);
        for(i=0;i<m;i++)
        {
            scanf("%d%d",&a,&b);
            map[a][b]=map[b][a]=0;//表示两地已互联,距离为0; 
        }    
        
        Prime(); 
    } 
    return 0;
} 

抱歉!评论已关闭.