现在的位置: 首页 > 综合 > 正文

HDU 1016 Prime Ring Problem DFS

2018年01月20日 ⁄ 综合 ⁄ 共 1289字 ⁄ 字号 评论关闭

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26913    Accepted Submission(s): 12008

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in
lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
/*
HDOJ 1016 DFS
*/

#include<iostream>
#include<stdio.h>
using namespace std;

int n,arr[50],visit[21];

int check(int x)
{
    int i;
    for(i=2;i<x;i++)
        if(x%i==0)
            return 0;
    return 1;
}

void DFS(int x,int k)
{
    int i;
    
    arr[x]=k;visit[k]=1;//arr[1]=1代表第1个是1 
    
    if(x==n)
    {
        if(check(arr[x]+arr[1]))
        {
            printf("1");
            for(i=2;i<=n;i++)
                printf(" %d",arr[i]);
            printf("\n");
        }
        return ;
    }
    
    for(i=1;i<=n;i++)
    {
        if(!visit[i]&&check(arr[x]+i))//已经访问的,满足条件就继续 
        {
            DFS(x+1,i);
            visit[i]=0;
        }
    }
    return ;
}
int main(){
    int k=1;
    while(scanf("%d",&n)!=EOF)
    {
        printf("Case %d:\n",k++);
        memset(visit,0,sizeof(visit));
        DFS(1,1);
        printf("\n");
    }
    
    return 0;
}

抱歉!评论已关闭.