现在的位置: 首页 > 综合 > 正文

HDU 1069 Monkey and Banana DP

2018年01月20日 ⁄ 综合 ⁄ 共 2640字 ⁄ 字号 评论关闭

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7076    Accepted Submission(s): 3641

Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall
be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.
The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions
of the base and the other dimension was the height.
They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly
smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.
Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
Sample Input
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
Sample Output
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
/*
HDU 1069 Monkey and Banana
DP题 三个参数 有三种高h  长度2个参数按大小给x y
这样每个块 有三种情况按长度进行排序 求最大上升子序列 
*/
#include<iostream>
#include<algorithm>
using namespace std;

struct rect{
    int x;
    int y;
    int h;
};

bool cmp(rect a,rect b)
{
    if(a.x!=b.x) return a.x>b.x;
        else if(a.y!=b.y) return a.y>b.y;
}

int main(){
    
    int i,k,z,a,b,c,max,result,n,j;
    rect node[91];
    int dp[91];
    z=1;
    while(cin>>n&&n)
    {
        k=0;
        for(i=0;i<n;i++)
        {
            scanf("%d%d%d",&a,&b,&c);//三种高  
            node[k].x=a>b?a:b;
            node[k].y=a>b?b:a;
            node[k++].h=c;
            
            node[k].x=c>b?c:b;
            node[k].y=c>b?b:c;
            node[k++].h=a;
            
            node[k].x=a>c?a:c;
            node[k].y=a>c?c:a;
            node[k++].h=b;
        }
        sort(node,node+n*3,cmp);
        
        dp[0]=node[0].h;
        result=dp[0];
        for(i=1;i<3*n;i++)
        {
            max=0;
            for(j=0;j<i;j++)
                if(node[j].x>node[i].x&&node[j].y>node[i].y)
                    if(dp[j]>max)
                        max=dp[j];
            dp[i]=max+node[i].h;
            if(result<dp[i])
                result=dp[i];    
        }
        printf("Case %d: maximum height = %d\n",z++,result);
    }
    
    return 0;
}

抱歉!评论已关闭.