现在的位置: 首页 > 综合 > 正文

HDU 3371 Connect the Cities 【最小生成树】

2018年01月21日 ⁄ 综合 ⁄ 共 1979字 ⁄ 字号 评论关闭

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10573    Accepted Submission(s): 2999

Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities
again, but they don’t want to take too much money.  
 

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected
cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 

Sample Input
1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
 

Sample Output
1
 

/*题解: 
    最小生成树问题,Kruskal算法求解。
此题与以前做的问题的不同点在于问题给出t个城市之间已相互 
连通。然后让你求最小花费。我的解决方案是先将相互连通的并在一起。 
然后,再求出最小花费。注意:提交时使用GNU C++超时,使用Visual C++ AC.耗时921MS 
*/

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int pre[505];
int find(int x)
{
    return x==pre[x]?x:pre[x]=find(pre[x]);
}
int join(int x,int y)
{
    int fx=find(x),fy=find(y);
    if(fx!=fy)
    {
        pre[fx]=fy;
        return 1; 
    }
    return 0;
}
struct edge
{
    int from;
    int to;
    int d;
}e[25002*3];
int cmp(edge a,edge b)
{
    return a.d<b.d;
}
int main()
{
    int T,n,m,k,i,j,t,s;
    scanf("%d",&T);
    while(T--)
    {
        memset(e,0,sizeof(e));
        scanf("%d %d %d",&n,&m,&k);
        for(i=1; i<=n; i++) pre[i]=i;
        for(i=1; i<=m; i++)
        {
            scanf("%d %d %d",&e[i].from,&e[i].to,&e[i].d);
        }
        //将已联通的并起来。 
        int p,q;
        while(k--)
        {
            scanf("%d %d",&t,&p);
            for(i=1; i<t; i++)
            {
                scanf("%d",&q);
                join(p,q);
            }
        }
        sort(e+1,e+m+1,cmp);
        
        for(i=1,s=0; i<=m; i++)
        {
            if(join(e[i].from,e[i].to))
            {
                 s+=e[i].d;
            }
        }
        int cnt=0;
        for(i=1; i<=n; i++)
        {
            if(pre[i]==i)
            cnt++;
        }
        if(cnt==1) printf("%d\n",s);
        else
            printf("-1\n");
    }
    return 0;
} 

抱歉!评论已关闭.