现在的位置: 首页 > 综合 > 正文

HDU 5011 Game 【Nim博弈】

2018年01月21日 ⁄ 综合 ⁄ 共 1216字 ⁄ 字号 评论关闭

Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 520    Accepted Submission(s): 394


Problem Description
Here is a game for two players. The rule of the game is described below: 

● In the beginning of the game, there are a lot of piles of beads.

● Players take turns to play. Each turn, player choose a pile i and remove some (at least one) beads from it. Then he could do nothing or split pile i into two piles with a beads and b beads.(a,b > 0 and a + b equals to the number of beads of pile i after removing) 

● If after a player's turn, there is no beads left, the player is the winner.

Suppose that the two players are all very clever and they will use optimal game strategies. Your job is to tell whether the player who plays first can win the game.

 


Input
There are multiple test cases. Please process till EOF.

For each test case, the first line contains a postive integer n(n < 105) means there are n piles of beads. The next line contains n postive integer, the i-th postive integer ai(ai < 231) means there are ai beads
in the i-th pile.

 


Output
For each test case, if the first player can win the game, ouput "Win" and if he can't, ouput "Lose"
 


Sample Input
1 1 2 1 1 3 1 2 3
 


Sample Output
Win Lose Lose
 

#include<cstdio>
int main(){
	int t,n,m;
	while(scanf("%d",&n)!=EOF)
	{
		scanf("%d",&m);
		t=m;
		for(int i=1; i<n; i++)
		{
			scanf("%d",&m);
			t^=m;
		}
		if(t==0) printf("Lose\n");
		else printf("Win\n");
	}
	return 0;
}

抱歉!评论已关闭.