现在的位置: 首页 > 综合 > 正文

HDU 1509 Windows Message Queue 【优先队列】

2018年01月21日 ⁄ 综合 ⁄ 共 1826字 ⁄ 字号 评论关闭

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3947    Accepted Submission(s): 1556

Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue.
Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting
messages to and getting message from the message queue.
 

Input
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter
and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
 

Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.
 

Sample Input
GET PUT msg1 10 5 PUT msg2 10 4 GET GET GET
 

Sample Output
EMPTY QUEUE! msg2 10 msg1 10 EMPTY QUEUE!
 
#include<cstdio>
#include<queue>
using namespace std;
struct ss
{
    friend bool operator <(const ss a,const ss b)//默认的que插入是从大到小
    {
        if(a.p>b.p) return 1;
        else if(a.p==b.p)
        {
            if(a.num>b.num) return 1;
            else return 0;
        }
        else return 0;
    }
    int p,num,para;
    char str[10];
}; 
int main()
{
    char s[10],str[10];
    int a,b,j=0;
    ss q;
    priority_queue<ss>Q;
    while(scanf("%s",s)!=EOF)
    {
        if(s[0]=='G')
        {
            if(Q.empty())
            {
                printf("EMPTY QUEUE!\n");
            }
            else
            {
                printf("%s %d\n",Q.top().str,Q.top().para);
                Q.pop();
            }
        }
        else
        {
            j++;
            scanf("%s %d %d",str,&a,&b);
            q.num=j;
            q.p=b;
            q.para=a;
            strcpy(q.str,str);
            Q.push(q);
        }
    }
    return 0;
}

抱歉!评论已关闭.