现在的位置: 首页 > 综合 > 正文

HDU 1017 A Mathematical Curiosity

2018年01月21日 ⁄ 综合 ⁄ 共 1445字 ⁄ 字号 评论关闭

A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27266    Accepted Submission(s): 8681

Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

 

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 

Sample Input
1 10 1 20 3 30 4 0 0
 

Sample Output
Case 1: 2 Case 2: 4 Case 3: 5
 

Source
 

/*题解:
    题目不难,由于数据量不大n<100,所以可以直接暴力解决,令人蛋疼的是格式问题。
格式需要注意:
      先输入一个整数N,整数后要输入换行。
       N代表有N组测试数据,每组测试数据以0 0结束。
      这N组测试数据每两组之间有换行,最后一组无换行。 
*/

#include<cstdio>
#include<cmath>
int fun(int n,int m)
{
    int t,a,b,count;
    for(b=2,count=0; b<n; b++)
    {
        for(a=1; a<b; a++)
        {
            t=(a*a+b*b+m)/(a*b);
            if(t*a*b==a*a+b*b+m)
                count++;
        }
    }
    return count;
} 
int main()
{
    int N,n,m,i,t;
    scanf("%d",&N);
    getchar();
    while(N--)
    {    
        t=0;
        while(scanf("%d %d",&n,&m)&&(n||m))
        {
            t++;
            printf("Case %d: %d\n",t,fun(n,m));    
        }
        if(N) printf("\n");
    }
    return 0;
}

抱歉!评论已关闭.