现在的位置: 首页 > 综合 > 正文

hdu 1789 Doing Homework again

2018年01月21日 ⁄ 综合 ⁄ 共 1572字 ⁄ 字号 评论关闭

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6840    Accepted Submission(s): 4072

Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce
his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced
scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
0 3 5
 

/*题解:
     贪心问题,对罚时排序,罚时大的排前面。 
*/ 

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct st
{
    int d;
    int score;
}e[1010];
int cmp(st a,st b)
{
    return a.score>b.score;
}
int main()
{
    int T,n,i,j,max,sum,vis[1010];
    scanf("%d",&T);
    while(T--)
    {
        memset(vis,0,sizeof(vis));
        memset(e,0,sizeof(e));
        scanf("%d",&n);
        max=-1;
        for(i=0; i<n; i++)
        {
            scanf("%d",&e[i].d);
            if(e[i].d>max)
                max=e[i].d;
        }
        for(i=0; i<n; i++)
            scanf("%d",&e[i].score);
        sort(e,e+n,cmp);
        for(i=0,sum=0; i<n; i++)
        {
            for(j=e[i].d; j>0; j--)
            {
                if(!vis[j])
                {
                    vis[j]=1;
                    break;
                }
            }
            if(j==0)
            sum+=e[i].score;
        }
        printf("%d\n",sum);
    } 
    return 0;
}

抱歉!评论已关闭.