现在的位置: 首页 > 综合 > 正文

hdu 1102 Constructing Roads

2018年01月21日 ⁄ 综合 ⁄ 共 2354字 ⁄ 字号 评论关闭

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14269    Accepted Submission(s): 5435

Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B,
or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within
[1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 

Sample Input
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
179
 
/*题解:
用Kruskal算法求最小生成树问题。这样的问题,可以用并查集(Union-Find Set)。
将每个连通分量看成一个集合,该集合包含了连通分量中所有的点。 
*/
// =====================================================================================
// 
//       Filename:  Constructing Roads.cpp
//    Description:  Constructing Roads
//      Algorithm:  Union-Find Set 
//         Status: 	RunTime:31ms 	RunMemory:452K 
//        Version:  Dev-C++ 5.5.3 
//        Created:  2014/9/9 23:50 
//       Revision:  none
//       Compiler:  G++
//         Author:  Tip of the finger melody, 1466989448@qq.com
//        Company:  none
//
// =====================================================================================

#include<cstdio>
#include<algorithm>
using namespace std;
int pre[10010];
int find(int x) //查
{
	return x==pre[x]?x:pre[x]=find(pre[x]);
}
int join(int x,int y,int z,int *p)//并
{
	int fx=find(x),fy=find(y);
	if(fx==fy) return 0;
	else
	{
		pre[fy]=fx;
		*p+=z;
	}
	return 1;
}
struct dege
{
	int a;
	int b;
	int d;
}e[10010];
int cmp(dege x,dege y)
{
	return x.d<y.d;
}
int main(){
	int i,j,k,n,m,x,y,sum,a[110][110];
	while(scanf("%d",&n)!=EOF)
	{
		for(i=1; i<=n; i++)
		{
			for(j=1; j<=n; j++)
			{
				scanf("%d",&a[i][j]);
			}
		}
		scanf("%d",&m);
		for(i=1; i<=m; i++)
		{
			scanf("%d %d",&x,&y);
			a[x][y]=0;
		}
		for(i=1,k=1; i<=n; i++)
		{
			for(j=1; j<=n; j++)
			{
				pre[k]=k;
				e[k].a=i;
				e[k].b=j;
				e[k].d=a[i][j];
				k++;
			}
		}
		sort(e+1,e+1+k,cmp);
		for(i=1,sum=0; i<=k; i++)
		{
			join(e[i].a,e[i].b,e[i].d,&sum);
		}
		printf("%d\n",sum);
	}
}
【上篇】
【下篇】

抱歉!评论已关闭.