现在的位置: 首页 > 综合 > 正文

hdu 5155 Harry And Magic Box BC#25比赛1002

2018年01月21日 ⁄ 综合 ⁄ 共 2141字 ⁄ 字号 评论关闭

Harry And Magic Box

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 237    Accepted Submission(s): 120


Problem Description
One day, Harry got a magical box. The box is made of n*m grids. There are sparking jewel in some grids. But the top and bottom of the box is locked by amazing magic, so Harry can’t see the inside from the top or bottom. However, four sides of the box are transparent,
so Harry can see the inside from the four sides. Seeing from the left of the box, Harry finds each row is shining(it means each row has at least one jewel). And seeing from the front of the box, each column is shining(it means each column has at least one
jewel). Harry wants to know how many kinds of jewel’s distribution are there in the box.And the answer may be too large, you should output the answer mod 1000000007.
 


Input
There are several test cases.
For each test case,there are two integers n and m indicating the size of the box. 0n,m50.
 


Output
For each test case, just output one line that contains an integer indicating the answer.
 


Sample Input
1 1 2 2 2 3
 


Sample Output
1 7 25
Hint
There are 7 possible arrangements for the second test case. They are: 11 11 11 10 11 01 10 11 01 11 01 10 10 01 Assume that a grids is '1' when it contains a jewel otherwise not.

11。。虽然我在比赛时想到dp求解,我知道了初值dp[i][1]=dp[1][i]=1;但是我是没有找到状态转移方程。

网上看到这样一种解答,dp[i][j]从dp[i-k][j-1]转移而来。然后枚举前j-1列中k行为0的情况,并计数就好。
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<vector>
#include<algorithm>
#include<stack>
#include<queue>
#include<set>
#include<map>
#include<string>
#include<cstring>
#include<cmath>
#include<fstream>
typedef long long ll;
#define cl(a,n) memset(a,n,sizeof a )
using namespace std;
/****************************
       By:七柳先森丶
       Date: 1.1 2015
*****************************/
const int mx=55;
//感觉一道比较难的DP题。
#define mod 1000000007
ll c[mx][mx],dp[mx][mx],t[mx]; 
void work(){
	//求组合数。 
	for(int i=0; i<=50 ; i++){
		c[i][0]=c[i][i]=1;
		for(int j=1;j<i;j++)
			c[i][j]=(c[i-1][j-1]+c[i-1][j] )% mod;
	}
	t[0]=1;
	for(int i=1;i<=50;i++){
		t[i]=(2*t[i-1])% mod;
	}
	
	for(int i=1;i<=50;i++) dp[i][1]=dp[1][i]=1;
	//dp[i][j]是由dp[i-k][j-1]转移来的,是一种计数方式,只要不重复即可。 
	for(int i=2;i<=50;i++){
		for(int j=2;j<=50;j++){
			dp[i][j]=(dp[i][j-1]*(t[i]-1))%mod;
		for(int k=1;k<i;k++)
			dp[i][j]=(dp[i][j]+c[i][k]*t[i-k] % mod * dp[i-k][j-1] % mod)%mod; 
		}
	} 
}
int main()
{
	int n,m;
	work();
	while(scanf("%d%d",&n,&m)==2){
		printf("%d\n",(int)dp[n][m]);
	}
	
    return 0;
}

抱歉!评论已关闭.