现在的位置: 首页 > 综合 > 正文

fibonacci数列(二)

2018年01月21日 ⁄ 综合 ⁄ 共 1250字 ⁄ 字号 评论关闭

题目来源

fibonacci数列(二)

时间限制:1000 ms  |  内存限制:65535 KB
难度:3
描述

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the
Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

输入
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
输出
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
样例输入
0
9
1000000000
-1
样例输出
0
34
6875

题目大意:

      求斐波那契数列的第n项的最后四位数

思路:

     根据题意,求的最后四位即可(即对10000求模),所以再计算过程中不需要保留全部的有效位,根据斐波那契数列求得的规律( f(n) = f(n-1)+f(n-2) )来看,其后四位的数字有一定的规律可循,就是说后四位称周期性出现,我们要做的是求出这个周期T,并保留一个周期内的数据,这样就可以根据输入,快速输出对应的答案.

#include<stdio.h>
#define mod 10000  //对mod求模
int fib[20000];		//保留一个周期内的数据
int main()
{
	int n,T;
	fib[0] = 0;
    fib[1] = 1;
    int i = 2;
    do
    {
        fib[i] = (fib[i - 1] + fib[i - 2]) % mod;
        ++i;
    }while(fib[i - 1] != 1 || fib[i - 2] != 0);
	T=i-2;//求得周期
	while(scanf("%d",&n) && n!=-1){
		printf("%d\n",fib[n%T]);
	}
	return 0;
}
【上篇】
【下篇】

抱歉!评论已关闭.