现在的位置: 首页 > 综合 > 正文

杭电1040

2018年02月01日 ⁄ 综合 ⁄ 共 1532字 ⁄ 字号 评论关闭

As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30295    Accepted Submission(s): 12993


Problem Description
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!
 


Input
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in
the same line. 
It is guarantied that all integers are in the range of 32-int.
 


Output
For each case, print the sorting result, and one line one case.
 


Sample Input
2 3 2 1 3 9 1 4 7 2 5 8 3 6 9
 


Sample Output
1 2 3 1 2 3 4 5 6 7 8 9
 

代码如下:

#include <iostream>
#include <vector>
using namespace std;

int findSplit(vector<int>& arr, int low, int hei)
{
	int tmp = arr[low] ;
	while(low < hei)
	{
		while(low < hei && arr[hei] >= tmp) hei -- ;
		arr[low] = arr[hei] ;
		while(low < hei && arr[low] <= tmp) low ++ ;
		arr[hei] = arr[low] ;
	}
	arr[low] = tmp ;
	return low ;
}

void quickSort(vector<int>& arr, int low, int hei)
{
	if (low < hei)
	{
		int mid = findSplit(arr, low, hei) ;
		quickSort(arr, low, mid - 1) ;
		quickSort(arr, mid + 1, hei) ;
	}
}

int main(int argc, char** argv)
{
	int numOfCase ;
	cin >> numOfCase ;
	while(numOfCase)
	{
		numOfCase -- ;
		int numOfElement ;
		cin >> numOfElement ;
		vector<int> tmpEles(numOfElement, 0) ;
		for (int i = 0; i < numOfElement; ++ i)
			cin >> tmpEles[i] ;
		quickSort(tmpEles, 0, numOfElement - 1) ;

		for (int i = 0; i < numOfElement - 1; ++ i)
			cout << tmpEles[i] << " " ;
		cout << tmpEles[numOfElement - 1] << endl;

	}

	return 0 ;
}

抱歉!评论已关闭.