现在的位置: 首页 > 综合 > 正文

杭电1020

2018年02月01日 ⁄ 综合 ⁄ 共 937字 ⁄ 字号 评论关闭

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16699    Accepted Submission(s): 7120


Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

 


Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 


Output
For each test case, output the encoded string in a line.
 


Sample Input
2 ABC ABBCCC
 


Sample Output
ABC A2B3C

#include <iostream>
#include <cstring>
using namespace std;

int main(int argc, char **argv)
{
    int num;
    string str;
    cin >> num;
    for ( int i =0; i < num; ++ i)
    {
        cin >> str;
        int j = 0;
        while (j < str.length()) 
        {
            char ch = str[j];
            int count = 0;
            while (ch == str[j] && j < str.length()) 
            {
                ++ j;
                ++ count;
            }
            if ( 1 != count )cout << count;
            cout << ch;
        }
        cout << endl;
        
    }
}

【上篇】
【下篇】

抱歉!评论已关闭.