现在的位置: 首页 > 综合 > 正文

杭电1004 STL map

2018年02月01日 ⁄ 综合 ⁄ 共 1625字 ⁄ 字号 评论关闭

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43973    Accepted Submission(s): 15540


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

 


Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

 


Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 


Sample Input
5 green red blue red red 3 pink orange pink 0
 


Sample Output
red pink

 

//
//  main.cpp
//  TestC++07
//
//  Created by fei dou on 12-8-13.
//  Copyright (c) 2012年 vrlab. All rights reserved.
//

#include <iostream>
#include <map>
#include <vector>
#include <cstring>
using namespace std;

int main (int argc, const char * argv[])
{

    vector<string> results;
    
    int num;
    while (cin >> num) 
    {
        if (num == 0) break;
        map<string, int> colorCountMap;
        for (int i = 0; i < num ; ++ i)
        {
            string temp;
            cin >> temp;
            if (colorCountMap.find(temp) == colorCountMap.end())//说明没有找到
            {
                colorCountMap[temp] = 1;
            }
            else
            {
            
                colorCountMap[temp] += 1;
            }
        }
        
        string temp = (*colorCountMap.begin()).first;
        for (map<string, int>::iterator it = colorCountMap.begin(); it != colorCountMap.end(); ++ it)
            if ((*it).second > colorCountMap[temp])
                temp = (*it).first;//寻找最大的那个元素
        
        results.push_back(temp);
            
    }
    
    for (int i = 0; i < results.size(); ++ i )
        cout << results[i] << endl;
    return 0;
}

【上篇】
【下篇】

抱歉!评论已关闭.