现在的位置: 首页 > 综合 > 正文

HDOJ 1020 ENcoding

2018年02月20日 ⁄ 综合 ⁄ 共 912字 ⁄ 字号 评论关闭

 

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.
2. If the length of the sub-string is 1, '1' should be ignored.
 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 
Output
For each test case, output the encoded string in a line.
 
Sample Input
2 ABC ABBCCC
 
Sample Output
ABC A2B3C
 思路:其实是统计连续字符的个数,然后输出 个数 和字符,一开始想复杂了, 用了count ,结果错了。
#include <iostream>
#include <string>

using namespace std ;

int main()
{
	int t ;
	cin >> t ;
	while(t--)
	{
		string s;
		cin >> s ;
		int len = s.size();
		int count = 1 ;
		for ( int i = 0 ; i < len ; ++i)
		{
			 if ( s[i]== s[i+1]) count++;
			 else {
			 	if ( count <= 1)
			 	{
			 		cout << s[i] ;
			 		count = 1 ;
			 	}
			 	else 
			 	{
			 		cout << count << s[i] ;
			 		count = 1 ;
			 	}			 
			 }		 
		}
			cout << endl ;	  
	}
	return 0 ;
}

抱歉!评论已关闭.