现在的位置: 首页 > 综合 > 正文

POJ 3006 Dirichlet’s Theorem on Arithmetic Progressions(素数筛选法) –from lanshui_Yang

2018年02月21日 ⁄ 综合 ⁄ 共 2480字 ⁄ 字号 评论关闭

Description

If a and d are relatively prime positive integers, the arithmetic sequence beginning with a and increasing by d, i.e., aa + da + 2da + 3d,a +
4d, ..., contains infinitely many prime numbers. This fact is known as Dirichlet's Theorem on Arithmetic Progressions, which had been conjectured by Johann Carl Friedrich Gauss (1777 - 1855) and was proved by Johann Peter Gustav Lejeune Dirichlet
(1805 - 1859) in 1837.

For example, the arithmetic sequence beginning with 2 and increasing by 3, i.e.,

2, 5, 8, 11, 14, 17, 20, 23, 26, 29, 32, 35, 38, 41, 44, 47, 50, 53, 56, 59, 62, 65, 68, 71, 74, 77, 80, 83, 86, 89, 92, 95, 98, ... ,

contains infinitely many prime numbers

2, 5, 11, 17, 23, 29, 41, 47, 53, 59, 71, 83, 89, ... .

Your mission, should you decide to accept it, is to write a program to find the nth prime number in this arithmetic sequence for given positive integers ad, and n.

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers ad, and n separated by a space. a and d are relatively prime. You may assume a <= 9307, d <= 346,
and n <= 210.

The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of as many lines as the number of the input datasets. Each line should contain a single integer and should never contain extra characters.

The output integer corresponding to a dataset adn should be the nth prime number among those contained in the arithmetic sequence beginning with a and increasing by d.

FYI, it is known that the result is always less than 106 (one million) under this input condition.

Sample Input

367 186 151
179 10 203
271 37 39
103 230 1
27 104 185
253 50 85
1 1 1
9075 337 210
307 24 79
331 221 177
259 170 40
269 58 102
0 0 0

Sample Output

92809
6709
12037
103
93523
14503
2
899429
5107
412717
22699
25673
           题目大意:给你三个数 a,d,n;其中 a 是素数,求数列{a,   a+d,   a+2d,   a+3d,   a+4d,   a+5d ……}中 第 n 个素数是多少。。。。
           Ps:此题 宜用 素数筛选法 (又名素数表法),如果 按一般方法 每个数都要判断 是否为素数 ,
   很容易TLE!! 
           具体 讲解请看代码:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN = 1000005;  // 注意 : 题中 数的范围 是 10^6,所以 数组应该开得 稍大一点
int sushu[MAXN];
void find()   // 筛选素数  ,先把 所有的数 都 "假定" 为 素数 全部赋值为 0,(如果 此处不理解 请继续 往下看。。) 
{
    int i,j;
    sushu[0]=1;  //  例如 sushu[2] = 0,意为 2 是素数 ,sushu[4] = 1,意为 4 不是素数 
                //0 和 1 不是素数 ,所以sushu[0]、sushu[1]的值 为 1
    sushu[1]=1;
    for(i=2;i<=MAXN-1;i++)  // 注意: i的值 从 2 开始(因为 2 是素数)
    {
        if(sushu[i]==0)
        {
            for(j=i*2;j<=MAXN-1;j+=i)  // 注意看此处 变量 j 的初始值 ,以及j 的变化,                                                                                     //很好理解,如果i 是素数,那么 i*2,i*3……,一定不是素数
            {
                sushu[j]=1;          // j 不是素数 ,所以 把 sushu[j] 的值 赋为 1
            }
        }
    }
}
int main()
{
    memset(sushu,0,sizeof(sushu));  // 把所有的 数 的值初始化为 0
    find();
    int a,d,n;
    while (scanf("%d%d%d",&a,&d,&n)!=EOF)
    {
        if(a == 0 && d == 0 && n == 0)
        break;
        int count = 0;  // 变量count 的作用 是 计数器
        int i;
        for(i=a;;i+=d)
        {
            if(sushu[i] == 0)
            count ++;
            if(count == n)
            {
                printf("%d\n",i);
                break;
            }
        }
    }
    return 0;
}

抱歉!评论已关闭.