现在的位置: 首页 > 综合 > 正文

POJ1733—Parity game

2018年02月21日 ⁄ 综合 ⁄ 共 3407字 ⁄ 字号 评论关闭
Parity game
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6595   Accepted: 2562

Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively)
and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have
received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions
asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit
in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence
of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3

Source

CEOI 1999

其实就是一个经典带权并查集的改造,cnt[i]表示i到根节点的1的个数的奇偶性,然后可以搞了

/*************************************************************************
    > File Name: poj1733.cpp
    > Author: ALex
    > Mail: 405045132@qq.com 
    > Created Time: 2015年01月22日 星期四 21时28分53秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 10010;

int cnt[N];
int xis[N];
int ret;
int father[N];
char str[10];
struct node
{
	int l, r;
	bool flag;
}que[N];

int BinSearch (int val)
{
	int l = 1;
	int r = ret;
	int mid;
	while (l <= r)
	{
		mid = (l + r) >> 1;
		if (xis[mid] > val)
		{
			r = mid - 1;
		}
		else if (xis[mid] < val)
		{
			l = mid + 1;
		}
		else
		{
			break;
		}
	}
	return mid;
}

int find (int x)
{
	if (father[x] == -1)
	{
		return x;
	}
	int fa = father[x];
	father[x] = find (father[x]);
	cnt[x] ^= cnt[fa];
	return father[x];
}

int main ()
{
	int n, m;
	int l, r;
	while (~scanf("%d", &n))
	{
		memset (father, -1, sizeof(father));
		scanf("%d", &m);
		ret = 0;
		for (int i = 1; i <= m; ++i)
		{
			scanf("%d%d%s", &l, &r, str);
			--l;
			que[i].l = l;
			que[i].r = r;
			if (str[0] == 'e')
			{
				que[i].flag = 0; //偶数个1
			}
			else
			{
				que[i].flag = 1; //奇数个1
			}
			xis[++ret] = l;
			xis[++ret] = r;
		}
		sort (xis + 1, xis + 1 + ret);
		ret = unique (xis + 1, xis + 1 + ret) - xis - 1;
		int ans = 0;
		for (int i = 1; i <= m; ++i)
		{
			l = BinSearch (que[i].l);
			r = BinSearch (que[i].r);
			int f1 = find(l);
			int f2 = find(r);
//			printf("%d的父亲%d, %d的父亲%d\n", l, f1, r, f2);
			if (f1 == f2)
			{
				if ((cnt[l] ^ cnt[r]) != que[i].flag)
				{
					break;
				}
				++ans;
			}
			else
			{
				if (f1 < f2)
				{
					father[f2] = f1;
//					printf("%d 的 父亲 %d\n", f2, f1);
					cnt[f2] = cnt[l] ^ que[i].flag ^ cnt[r];
				}
				else
				{
					father[f1] = f2;
//					printf("%d 的 父亲 %d\n", f1, f2);
					cnt[f1] = cnt[l] ^ que[i].flag ^ cnt[r];
				}
				++ans;
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}

抱歉!评论已关闭.