现在的位置: 首页 > 综合 > 正文

POJ1125——Stockbroker Grapevine

2018年02月21日 ⁄ 综合 ⁄ 共 3147字 ⁄ 字号 评论关闭
Stockbroker Grapevine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 27547   Accepted: 15264

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect,
you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass
the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community.
This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact
with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each
pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of
stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person,
measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the
message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2 
3 10

Source

给你人与人之间传递消息的速率(单向),然后问你该让哪一个人来传,所花时间最短,所以就是一个最短路问题,用floyd可以很好地解决

#include <map>  
#include <set>  
#include <list>  
#include <stack>  
#include <queue>  
#include <vector>  
#include <cmath>  
#include <cstdio>  
#include <cstring>  
#include <iostream>  
#include <algorithm>  
  
using namespace std; 

int dp[105][105];

const int inf = 0x3f3f3f3f;

int main()
{
	int n, x, y, z;
	while (~scanf("%d", &n), n)
	{
		memset (dp, inf, sizeof(dp));
		for (int i = 1; i <= n; i++)
		{
			scanf("%d", &x);
			dp[i][i] = 0;
			for (int j = 0; j < x; j++)
			{
				scanf("%d%d", &y, &z);
				dp[i][y] = z;
			}
		}
		for (int k = 1; k <= n; k++)
		{
			for (int i = 1; i <= n; i++)
			{
				for (int j = 1; j <= n; j++)
				{
					dp[i][j] = min(dp[i][j], dp[i][k] + dp[k][j]);
				}
			}
		}
		int ans = inf, res;
		for (int i = 1; i <= n; i++)
		{
			int tmp = 0;
			for (int j = 1; j <= n; j++)
			{
				tmp = max(tmp, dp[i][j]);
			}
			if (ans > tmp)
			{
				ans = tmp;
				res = i;
			}
		}
		if (ans == inf)
		{
			printf("disjoint\n");
			continue;
		} 
		printf("%d %d\n", res, ans);
	}
	return 0;
}

抱歉!评论已关闭.