现在的位置: 首页 > 综合 > 正文

zoj 3777 状压dp

2018年02月21日 ⁄ 综合 ⁄ 共 2636字 ⁄ 字号 评论关闭

Problem Arrangement


Time Limit: 2 Seconds      Memory Limit: 65536 KB


The 11th Zhejiang Provincial Collegiate Programming Contest is coming! As a problem setter, Edward is going to arrange the order of the problems. As we know, the arrangement will have
a great effect on the result of the contest. For example, it will take more time to finish the first problem if the easiest problem hides in the middle of the problem list.

There are N problems in the contest. Certainly, it's not interesting if the problems are sorted in the order of increasing difficulty. Edward decides to arrange the problems
in a different way. After a careful study, he found out that the i-th problem placed in the j-th position will add Pij points of "interesting value" to the contest.

Edward wrote a program which can generate a random permutation of the problems. If the total interesting value of a permutation is larger than or equal to M points, the permutation
is acceptable. Edward wants to know the expected times of generation needed to obtain the first acceptable permutation.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (1 <= N <= 12) and M (1 <= M <= 500).

The next N lines, each line contains N integers. The j-th integer in the i-th line is Pij (0 <= Pij <= 100).

Output

For each test case, output the expected times in the form of irreducible fraction. An irreducible fraction is a fraction in which the numerator and denominator are positive integers and
have no other common divisors than 1. If it is impossible to get an acceptable permutation, output "No solution" instead.

Sample Input

2
3 10
2 4 1
3 2 2
4 5 3
2 6
1 3
2 4

Sample Output

3/1
No solution
求一些数的全排列,求对应的值超过某一个数m的期望
dp[st][c]表示状态st的时候得到分数c的个数。
状态st表示已经放了哪些数,并且将要放第(st中1的个数)个数。
求大于等于m的方案数,可以将大于m的都等价于等于m。
方程 dp[st'][c+ma[j][cnt]]+=dp[st][c]
ma[j][cnt]表示将第j个数放在第cnt个位置上。尼玛终于搞明白了。
#include<cstring>
#include<iostream>
#include<cstdio>
#include<vector>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<string>
#include<cstdlib>
using namespace std;
#define re freopen("in.txt","r",stdin)
#define we freopen("out.txt","w",stdout)
#define maxn 511
#define maxm maxn*maxn/2
#define ll long long
#define ld long double


int ma[15][15];
int dp[1<<12][511];
int gcd(int a,int b)
{
    while(b){
        int t=a%b;
        a=b;
        b=t;
    }
    return a;
}
int main()
{
    int nc;
    re;
    scanf("%d",&nc);
    while(nc--){
        memset(dp,0,sizeof(dp));
        memset(ma,0,sizeof(ma));
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
            scanf("%d",&ma[i][j]);
        dp[0][0]=1;
        int all=1<<n;
        int cnt=0;
        for(int st=0;st<all;st++){
            cnt=0;
            for(int c=0;c<n;c++)
                if(st&(1<<c))cnt++;
            for(int c=0;c<=m;c++){
                if(dp[st][c]){
                    for(int j=0;j<n;j++)
                    if(!(st&(1<<j))){
                        dp[st|(1<<j)][min(m,c+ma[j][cnt])]+=dp[st][c];
                    }
                }
            }
        }
        int ans=dp[all-1][m];
        int b=1;
        for(int j=2;j<=n;j++)
            b*=j;
        int gc=gcd(ans,b);
        ans/=gc;
        b/=gc;
        if(ans)
            printf("%d/%d\n",b,ans);
        else puts("No solution");
    }
    return 0;
}

抱歉!评论已关闭.