现在的位置: 首页 > 综合 > 正文

POJ1837Balance(分组背包)

2018年02月21日 ⁄ 综合 ⁄ 共 2300字 ⁄ 字号 评论关闭
Balance
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 11042   Accepted: 6855

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25.
Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis
(when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the
hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

题目大意:有一把称,上有C个沟子在不同的位置,可挂法码,有G个法码可以挂,问把全部法码挂上去有多少种平衡方法。

解题:因为必须把所有的法码都要挂上去,去以可以用分组背包,dp[gn][v+H[i]*G[gn]]的组成是用第gn个法码,第i个沟子去跟dp[gn-1][v]组合。

PS:如果碰到的题目说,必须把所有的东西都要用上就可以用分组背包。

#include<stdio.h>
#include<string.h>

int dp[25][15005];

int main()
{
    int hn,gn,H[25],G[25],mid0=7500;//表示整体平移的多少,把负数变正数,0则变成mid0
    while(scanf("%d%d",&hn,&gn)>0)
    {
        for(int i=1;i<=hn; i++)
            scanf("%d",&H[i]);
        for(int i=1;i<=gn; i++)
            scanf("%d",&G[i]);

        memset(dp,0,sizeof(dp));
        dp[0][mid0]=1;//挂0个物品平衡
        for(int i=0;i<gn; i++)
            for(int v=0;v<=15000;v++)
            if(dp[i][v])//称上挂了前i个物品组成v的状态有多少种
            {
                for(int j=1;j<=hn; j++)
                    if(v+H[j]*G[i+1]>=0&&v+H[j]*G[i+1]<=15000)
                        dp[i+1][v+H[j]*G[i+1]]+=dp[i][v];
            }

        printf("%d\n",dp[gn][mid0]);
    }
}

抱歉!评论已关闭.