现在的位置: 首页 > 综合 > 正文

hdu1507Uncle Tom’s Inherited Land*(最大匹配,黑白染色)

2018年02月21日 ⁄ 综合 ⁄ 共 3229字 ⁄ 字号 评论关闭

Uncle Tom's Inherited Land*

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1943 Accepted Submission(s): 809
Special Judge

Problem Description
Your old uncle Tom inherited a piece of land from his great-great-uncle. Originally, the property had been in the shape of a rectangle. A long time ago, however, his great-great-uncle decided to divide the land into a grid of small
squares. He turned some of the squares into ponds, for he loved to hunt ducks and wanted to attract them to his property. (You cannot be sure, for you have not been to the place, but he may have made so many ponds that the land may now consist of several disconnected
islands.)

Your uncle Tom wants to sell the inherited land, but local rules now regulate property sales. Your uncle has been informed that, at his great-great-uncle's request, a law has been passed which establishes that property can only be sold in rectangular lots the
size of two squares of your uncle's property. Furthermore, ponds are not salable property.

Your uncle asked your help to determine the largest number of properties he could sell (the remaining squares will become recreational parks).

Input
Input will include several test cases. The first line of a test case contains two integers N and M, representing, respectively, the number of rows and columns of the land (1 <= N, M <= 100). The second line will contain an integer
K indicating the number of squares that have been turned into ponds ( (N x M) - K <= 50). Each of the next K lines contains two integers X and Y describing the position of a square which was turned into a pond (1 <= X <= N and 1 <= Y <= M). The end of input
is indicated by N = M = 0.

Output
For each test case in the input your program should first output one line, containing an integer p representing the maximum number of properties which can be sold. The next p lines specify each pair of squares which can be sold simultaneity.
If there are more than one solution, anyone is acceptable. there is a blank line after each test case. See sample below for clarification of the output format.

Sample Input
4 4 6 1 1 1 4 2 2 4 1 4 2 4 4 4 3 4 4 2 3 2 2 2 3 1 0 0

Sample Output
4 (1,2)--(1,3) (2,1)--(3,1) (2,3)--(3,3) (2,4)--(3,4) 3 (1,1)--(2,1) (1,2)--(1,3) (2,3)--(3,3)

Source
这题输出只要是合理都可以。
#include<stdio.h>
#include<string.h>
int map[5005][4],vist[5005],match[5005];
int find(int i)
{
    for(int j=0;j<4;j++)
    if(!vist[map[i][j]]&&map[i][j])
    {
        vist[map[i][j]]=1;
        if(match[map[i][j]]==0||find(match[map[i][j]]))
        {
            match[map[i][j]]=i; return 1;
        }
    }
    return 0;
}
int main()
{
    int n,m,mp[105][105],k,a,b,ans,x[2][5005],y[2][5005];
    while(scanf("%d%d",&n,&m)>0&&m+n!=0)
    {
        scanf("%d",&k);
        for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        mp[i][j]=1;
        while(k--)
        {
            scanf("%d%d",&a,&b); mp[a][b]=0;
        }
        int wn=0,bn=0;
        for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        if((i+j)%2&&mp[i][j])
        {
            bn++; mp[i][j]=bn; x[1][bn]=i; y[1][bn]=j;
        }
        else if(mp[i][j])
        {
            wn++; mp[i][j]=wn; x[0][wn]=i; y[0][wn]=j;
        }
        for(int i=1;i<=bn;i++)
             for(int j=0;j<4;j++)
                map[i][j]=0;
       for(int i=1;i<=wn;i++)
            match[i]=0;
        for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        if(mp[i][j]&&(i+j)%2)
        {
            if(i-1>0&&mp[i-1][j])map[mp[i][j]][2]=mp[i-1][j];
            if(j-1>0&&mp[i][j-1])map[mp[i][j]][0]=mp[i][j-1];
            if(j+1<=m&&mp[i][j+1])map[mp[i][j]][1]=mp[i][j+1];
            if(i+1<=n&&mp[i+1][j])map[mp[i][j]][3]=mp[i+1][j];
        }
        ans=0;
        for(int i=1;i<=bn;i++)
        {
            for(int j=1;j<=wn;j++)
                vist[j]=0;
            ans+=find(i);
        }
        printf("%d\n",ans);
        for(int i=1;i<=wn;i++)
        if(match[i])
        {
            int x1,y1,x2,y2;
            x1=x[0][i]; y1=y[0][i];
            x2=x[1][match[i]]; y2=y[1][match[i]];
            if(x1>x2||x1==x2&&y1>y2)
            printf("(%d,%d)--(%d,%d)\n",x2,y2,x1,y1);
            else
            printf("(%d,%d)--(%d,%d)\n",x1,y1,x2,y2);
        }
        printf("\n");
    }
}

抱歉!评论已关闭.