现在的位置: 首页 > 综合 > 正文

HDU 4864 Task(贪心)

2018年02月22日 ⁄ 综合 ⁄ 共 2310字 ⁄ 字号 评论关闭

Task

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3587 Accepted Submission(s): 930

Problem Description
Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes
this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task
can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.

Input
The input contains several test cases.
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.

Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.

Sample Input
1 2 100 3 100 2 100 1

Sample Output
1 50004

Author
FZU

Source
方法一:机器匹配任务:首先机器和任务的时间和级别都按  从小到大排,再从第一个机器开始,找出从第一个任务开始找出所有任务的时间小于等于这台机器的时间,用数组计下每个等级出现的次数。再从等级数组中找一个等级最接近这台机器的等级。这样再找任务的时间复杂度是线性的为为O(m)。
方法二:任务匹配机器:首先机器和任务的时间和级别都按  从大到小排,再从第一个任务开始,找出从第一个机器开始找出所有机器的时间大于等于这个任务的时间,用数组计下每个等级出现的次数。再从等级数组中找一个等级最接近这个任务的等级。这样再找机器的时间复杂度是线性的为为O(n)。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
    int x,y;
};
node mach[100005],task[100005];
bool cmp(node a,node b)
{
    if(a.x==b.x)
    return a.y>b.y;
    return a.x>b.x;
}
int main()
{
    int n,m,ans,x,y,level[105];
    __int64 sum;
    while(scanf("%d%d",&n,&m)>0)
    {
        memset(level,0,sizeof(level));

        for(int i=0;i<n;i++)
            scanf("%d%d",&mach[i].x,&mach[i].y);
        for(int i=0;i<m;i++)
        scanf("%d%d",&task[i].x,&task[i].y);

        sort(mach,mach+n,cmp);
        sort(task,task+m,cmp);
        ans=0; sum=0;
        int j=0;
        for(int i=0;i<m;i++)
        {
            while(j<n&&mach[j].x>=task[i].x)level[mach[j++].y]++;
            for(int lev=task[i].y; lev<=100;lev++)
            if(level[lev])
            {
                ans++; 
                sum+=500*task[i].x+2*task[i].y; 
                level[lev]--;
                break;
            }
        }
        printf("%d %I64d\n",ans,sum);
    }
}

抱歉!评论已关闭.